LEDE as Client Device - Connecting the LEDE device to an existing network

Hi, So i have a 2nd router R7800 sat behind a R7000, and i have set it up with the wan on the switch with the lan. In fact i have tried every guide i can find, no problem about getting this to work, I have a working switch with the wan port and the 4 lan ports acting correctl, i can get to luci via the static ip adress i set and ssh into it ok as well. What is flooring me is that i cannot update - opkg or get the cpu to ping out. Is there a fix for this? or have i missed something?
Many thanks for your help

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdab:46fd:f175::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.2'
	option gateway '192.168.0.1'
	option broadcast '192.168.0.255'
	option dns '192.168.0.1'

config interface 'wan'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'none'
	option auto '1'
	option type 'bridge'
	option ifname 'eth0.2 eth1'
	option gateway '192.168.0.1'
	option broadcast '192.168.0.255'
	option dns '192.168.0.1'
config interface 'wan6'
	option _orig_ifname 'eth0'
	option _orig_bridge 'false'
	option proto 'none'
	option auto '1'
	option type 'bridge'
	option ifname 'eth0.2 eth1'
	option gateway '192.168.0.1'
	option broadcast '192.168.0.255'
	option dns '192.168.0.1'
config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4 5 6'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'

When you are only a LAN device not doing any routing, don't have a wan network. Using the default switch configuration, put both eth0 and eth1 in the lan. Or move the WAN port into eth1's VLAN along with the 4 LAN ports, and don't use eth0.

In your current setup you have erroneously the same subnet 192.168.0.x on both lan and wan. That confuses routing.

Like already said, you don't want wan on this router, unless you really want/need double NAT.

EDIT:
If you do not want to modify VLAN settings and can sacrifice one LAN port, it is also very easy to config by using one LAN port to connect to the primary router. I do that myself. See explanation in Lede 17.01 RC1 DNS problem