LEDE 17.01 DHCP Server Not Working

Hey guys, I have one of those cheap A5-V11 3G/4G Mini Routers I'm trying to use for a small project. I'm able to successfully build the LEDE 17.01 firmware, but I'm running into issues with the DHCP config.

Here is a copy of my configs. I've attempted to enable logging in dnsmasq.conf by adding log-queries and log-dhcp and restarting the service, but i don't see anything being printed when looking at the syslog.

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/wlan/'
	option domain 'wlan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'wlan'
	option interface 'wlan'
	option start '2'
	option limit '254'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra 'server'
	
config dhcp 'lan'
	option interface 'lan'
	option start '2'
	option limit '254'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra 'server'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'

/etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	
config interface 'lan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wlan'
	option ifname 'wlan0'
	option proto 'dhcp'

/etc/config/firewall:

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT	
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT
	option masq		1
	option mtu_fix		1


# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT



# include a file with users custom iptables rules
config include
	option path /etc/firewall.user

I'm sure its a simple config issue, but I'm not sure what. Any help would be appreciated.

You must not run DHCP client and server on the same interface.

Can you tell me where that's configured at? Sorry, still learning. Basically I want any client that I connect via the LAN cable or WLAN to get a DHCP address from this little router.

Thanks.

It is supposed to work this way:

Interface IP address DHCP role
WAN Dynamic / Static DHCP client / -
LAN Static DHCP server

Or you can configure a Dumb AP.

have you changed that?

Yes, I set that as I want to be able to plug this mini router into my PC and have it assign my laptop a DHCP address. I'm not planning on actually ever using this as a router. This is for a project and it will never actually be connected to the internet.

Why did you think, you have to change the defaultconfig? After you installed openwrt and pluged in a cable, you got an ip, right?

https://openwrt.org/docs/guide-user/network/ipv4/start#downstream_configuration_for_lan-interfaces

option proto 'static'