LED issues with Gl.inet MT1300

I've seen a few threads discussing advanced LED control for this router, but I'd like to just do the basics with LuCI and the network LED trigger. I was trying to get my old router to work better while I wait for the OKOD issue to be solved for my new one, but I've run into a weird issue.

So, this router has one blue and one white LED. There's some sort of intelligence involved since they can do different brightness levels, but I'd like to just do a basic "blink when there's network traffic" on the white LED (ideally, on by default, then blink either off or brighter when there's traffic; I'm not too picky).

Issue is, I can't turn off the blue LED at all, even if I add a "blue LED off" control in the LED settings tab. I've also tried "on" in case it's inverted. In fact, unless I use timer, heartbeat, or netdev on the blue LED, I can't even get it to go dim (maybe it requires active control?). It's super bright, to the point that I've had complaints about it.

EDIT: For full disclosure, I am using 23.05.2, made with the buildroot. Everything else, even the guest Wi-Fi, works perfectly.

Also, the white LED seems to only have off and dim as available settings. Heartbeat, netdev, timer, etc seem to only make it vaguely visible against the background blue - it's clearly quite dim and hard to see. It's only visible against the dim blue (I finally set it to on for 1ms, off for some large number, but it is still on!) and it's more of a faint color change than anything else.

(The white LED's dimness might actually be the white LED failing; the OEM firmware ran it continually for some years and I noticed it wasn't all that bright then, but I will note that firmware didn't have the blue LED on so clearly THAT part is possible.)

Any clue what might be going on that I can't turn off the blue one?

LED config

config led
option sysfs 'white:system'
option trigger 'netdev'
option dev 'wan'
list mode 'tx'
list mode 'rx'

config led
option sysfs 'blue:run'
option trigger 'timer'
option delayon '1'
option delayoff '10000000'


Bonus points if there's a way to make it dim blue with no traffic, and blink white (with no blue) when there is traffic. Not sure if that's possible, and as I said the normal LED config tricks I do know aren't working because I can't turn the blue LED fully off!

Update:

I have discovered that the LED controls for this device appear to be very nonstandard. Specifically, they're based on an I2C command to what appears to be an external controller.

Obviously, stock OpenWRT would not have the daemon that normally controls this, but I've also seen that (at least some of) the usual UCI LED configuration works.
So I can only guess that there's a shim that calls the I2C commands.

However, as I noted earlier, this appears to have been misconfigured since "off" isn't actually the right value for at least the blue LED (and I can't even tell for white). In addition, the static modes don't seem to have any affect at all.

Is there anyone who would know where this command is translated from /sys/class/leds or UCI to the I2C command?

I'd really appreciate if someone could upstream the fixed config, too, but I don't have an account there and don't know where exactly the issue is to begin with.