Latest arm_cortex-a7_neon-vfpv4 packages seem broken

@ psherman
Thank you for the update instructions. I have indeed installed the updates because they were offered. Surely the belief in important security patches as with Linux distributions plays a role for me. I will probably wait for the next maintenance release.

1 Like

Nope, backup was taken from configuration that was solid for a weeks
If you want whole output:

|       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
root@OpenWrt:~# opkg install mod-udptunnel4 kmod-udptunnel6 kmod-wireguard wireguard-tools wireguard
Unknown package 'mod-udptunnel4'.
Installing kmod-udptunnel6 (4.14.171-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-udptunnel6_4.14.171-1_arm_cortex-a7_neon-vfpv4.ipk
Installing kmod-wireguard (4.14.171+0.0.20190702-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-wireguard_4.14.171%2b0.0.20190702-1_arm_cortex-a7_neon-vfpv4.ipk
Installing kmod-udptunnel4 (4.14.171-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-udptunnel4_4.14.171-1_arm_cortex-a7_neon-vfpv4.ipk
Installing wireguard-tools (1.0.20200319-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/wireguard-tools_1.0.20200319-1_arm_cortex-a7_neon-vfpv4.ipk
Installing libmnl0 (1.0.4-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/libmnl0_1.0.4-2_arm_cortex-a7_neon-vfpv4.ipk
Installing ip-tiny (5.6.0-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/ip-tiny_5.6.0-1_arm_cortex-a7_neon-vfpv4.ipk
Installing wireguard (1.0.20200506-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/wireguard_1.0.20200506-1_arm_cortex-a7_neon-vfpv4.ipk
Configuring libmnl0.
Configuring kmod-udptunnel4.
Configuring kmod-udptunnel6.
Configuring kmod-wireguard.
Configuring ip-tiny.
Configuring wireguard-tools.
Configuring wireguard.
Collected errors:
 * opkg_install_cmd: Cannot install package mod-udptunnel4.
root@OpenWrt:~# opkg install mod-udptunnel
Unknown package 'mod-udptunnel'.
Collected errors:
 * opkg_install_cmd: Cannot install package mod-udptunnel.
root@OpenWrt:~# opkg install kmod-udptunnel4
Package kmod-udptunnel4 (4.14.171-1) installed in root is up to date.
root@OpenWrt:~# opkg install luci-proto-wireguard luci-app-wireguard
Installing luci-proto-wireguard (git-20.069.54281-3fb8e3d) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-proto-wireguard_git-20.069.54281-3fb8e3d_all.ipk
Installing luci-app-wireguard (git-20.069.54281-3fb8e3d) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-app-wireguard_git-20.069.54281-3fb8e3d_all.ipk
Configuring luci-proto-wireguard.
Configuring luci-app-wireguard.
root@OpenWrt:~# Connection to openwrt closed by remote host.
Connection to openwrt closed.

Thats wireguard (BTW. wireguard tunneling is working just luci interface is broken)

DDNS

root@OpenWrt:~# opkg install ddns-scripts ddns-scripts_nsupdate luci-app-ddns
Installing ddns-scripts (2.7.8-20) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages/ddns-scripts_2.7.8-20_all.ipk
Installing ddns-scripts_nsupdate (2.7.8-20) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages/ddns-scripts_nsupdate_2.7.8-20_all.ipk
Installing libopenssl1.1 (1.1.1g-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/libopenssl1.1_1.1.1g-1_arm_cortex-a7_neon-vfpv4.ipk
Installing zlib (1.2.11-3) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/zlib_1.2.11-3_arm_cortex-a7_neon-vfpv4.ipk
Installing libatomic1 (7.5.0-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/packages/libatomic1_7.5.0-2_arm_cortex-a7_neon-vfpv4.ipk
Installing librt (1.1.24-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/packages/librt_1.1.24-2_arm_cortex-a7_neon-vfpv4.ipk
Installing libuv1 (1.34.2-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages/libuv1_1.34.2-1_arm_cortex-a7_neon-vfpv4.ipk
Installing bind-libs (9.16.2-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages/bind-libs_9.16.2-1_arm_cortex-a7_neon-vfpv4.ipk
Installing bind-client (9.16.2-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages/bind-client_9.16.2-1_arm_cortex-a7_neon-vfpv4.ipk
Installing luci-app-ddns (git-20.108.78014-f4651cb) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-app-ddns_git-20.108.78014-f4651cb_all.ipk
Installing luci-lib-ipkg (git-20.069.54281-3fb8e3d) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-lib-ipkg_git-20.069.54281-3fb8e3d_all.ipk
Configuring ddns-scripts.
Configuring luci-lib-ipkg.
Configuring luci-app-ddns.
Configuring libopenssl1.1.
Configuring zlib.
Configuring libatomic1.
Configuring librt.
Configuring libuv1.
Configuring bind-libs.
 192852  WARN : Service section disabled! - TERMINATE
Configuring bind-client.
 192852  WARN : No update_url found/defined or no update_script found/defined! - TERMINATE
Configuring ddns-scripts_nsupdate.
Collected errors:
 * resolve_conffiles: Existing conffile /etc/config/ddns is different from the conffile in the new package. The new conffile will be placed at /etc/config/ddns-opkg.

Also it is working (DNS records updated) but no luci status/configuration.
My worries are that now part of luci is stock/vanilla and some underlying modules are newer

root@OpenWrt:~# opkg list-installed | grep luci
liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
luci - git-20.057.55219-13dd17f-1
luci-app-ddns - git-20.108.78014-f4651cb
luci-app-firewall - git-20.057.55219-13dd17f-1
luci-app-opkg - git-20.057.55219-13dd17f-1
luci-app-wireguard - git-20.069.54281-3fb8e3d
luci-base - git-20.057.55219-13dd17f-1
luci-lib-ip - git-20.057.55219-13dd17f-1
luci-lib-ipkg - git-20.069.54281-3fb8e3d
luci-lib-jsonc - git-20.057.55219-13dd17f-1
luci-lib-nixio - git-20.057.55219-13dd17f-1
luci-mod-admin-full - git-20.057.55219-13dd17f-1
luci-mod-network - git-20.057.55219-13dd17f-1
luci-mod-status - git-20.057.55219-13dd17f-1
luci-mod-system - git-20.057.55219-13dd17f-1
luci-proto-ipv6 - git-20.057.55219-13dd17f-1
luci-proto-ppp - git-20.057.55219-13dd17f-1
luci-proto-wireguard - git-20.069.54281-3fb8e3d
luci-theme-bootstrap - git-20.057.55219-13dd17f-1
rpcd-mod-luci - 20191114

Regards
Weasel

router was restored by uboot procedure
using:
http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/openwrt-19.07.2-ipq40xx-generic-glinet_gl-b1300-squashfs-sysupgrade.bin
and looks vanilla after connecting http://192.168.1.1 (no root password etc.)

I don't see the install of luci-app-wireguard -- did you install that?

mod-udptunnel package is not found -- maybe you meant simply udptunnel?

1 Like

Typo, package was installed anyway

Installing kmod-udptunnel4 (4.14.171-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-udptunnel4_4.14.171-1_arm_cortex-a7_neon-vfpv4.ipk

I did not paste installation procedure but as you can see:

root@OpenWrt:~# opkg list-installed | grep luci
liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
luci - git-20.057.55219-13dd17f-1
luci-app-ddns - git-20.108.78014-f4651cb
luci-app-firewall - git-20.057.55219-13dd17f-1
luci-app-opkg - git-20.057.55219-13dd17f-1
luci-app-wireguard - git-20.069.54281-3fb8e3d
luci-base - git-20.057.55219-13dd17f-1
luci-lib-ip - git-20.057.55219-13dd17f-1
luci-lib-ipkg - git-20.069.54281-3fb8e3d
luci-lib-jsonc - git-20.057.55219-13dd17f-1
luci-lib-nixio - git-20.057.55219-13dd17f-1
luci-mod-admin-full - git-20.057.55219-13dd17f-1
luci-mod-network - git-20.057.55219-13dd17f-1
luci-mod-status - git-20.057.55219-13dd17f-1
luci-mod-system - git-20.057.55219-13dd17f-1
luci-proto-ipv6 - git-20.057.55219-13dd17f-1
luci-proto-ppp - git-20.057.55219-13dd17f-1
luci-proto-wireguard - git-20.069.54281-3fb8e3d
luci-theme-bootstrap - git-20.057.55219-13dd17f-1
rpcd-mod-luci - 20191114

Regards
Weasel

But you did...

Unless the luci-app-wireguard was installed before or after this command, it wasn't installed here.

I just did the following from a virgin 19.07.2 VM:

opkg update
opkg install wireguard luci-app-wireguard

Working perfectly -- Wireguard status is listed at the very bottom of the Status dropdown menu.

root@OpenWrt:~# opkg remove luci-app-ddns
Removing package luci-app-ddns from root...
That fixed Overview.

And whole installation, yes i splitted into two commands

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07.2, r10947-65030d81f3
 -----------------------------------------------------
root@OpenWrt:~# opkg install mod-udptunnel4 kmod-udptunnel6 kmod-wireguard wireguard-tools wireguard
Unknown package 'mod-udptunnel4'.
Installing kmod-udptunnel6 (4.14.171-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-udptunnel6_4.14.171-1_arm_cortex-a7_neon-vfpv4.ipk
Installing kmod-wireguard (4.14.171+0.0.20190702-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-wireguard_4.14.171%2b0.0.20190702-1_arm_cortex-a7_neon-vfpv4.ipk
Installing kmod-udptunnel4 (4.14.171-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926/kmod-udptunnel4_4.14.171-1_arm_cortex-a7_neon-vfpv4.ipk
Installing wireguard-tools (1.0.20200319-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/wireguard-tools_1.0.20200319-1_arm_cortex-a7_neon-vfpv4.ipk
Installing libmnl0 (1.0.4-2) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/libmnl0_1.0.4-2_arm_cortex-a7_neon-vfpv4.ipk
Installing ip-tiny (5.6.0-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/ip-tiny_5.6.0-1_arm_cortex-a7_neon-vfpv4.ipk
Installing wireguard (1.0.20200506-1) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base/wireguard_1.0.20200506-1_arm_cortex-a7_neon-vfpv4.ipk
Configuring libmnl0.
Configuring kmod-udptunnel4.
Configuring kmod-udptunnel6.
Configuring kmod-wireguard.
Configuring ip-tiny.
Configuring wireguard-tools.
Configuring wireguard.
Collected errors:
 * opkg_install_cmd: Cannot install package mod-udptunnel4.
root@OpenWrt:~# opkg install mod-udptunnel
Unknown package 'mod-udptunnel'.
Collected errors:
 * opkg_install_cmd: Cannot install package mod-udptunnel.
root@OpenWrt:~# opkg install kmod-udptunnel4
Package kmod-udptunnel4 (4.14.171-1) installed in root is up to date.
root@OpenWrt:~# opkg install luci-proto-wireguard luci-app-wireguard
Installing luci-proto-wireguard (git-20.069.54281-3fb8e3d) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-proto-wireguard_git-20.069.54281-3fb8e3d_all.ipk
Installing luci-app-wireguard (git-20.069.54281-3fb8e3d) to root...
Downloading http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci/luci-app-wireguard_git-20.069.54281-3fb8e3d_all.ipk
Configuring luci-proto-wireguard.
Configuring luci-app-wireguard.
root@OpenWrt:~# Connection to openwrt closed by remote host.
Connection to openwrt closed.

Regards
Rafał

is it fixed now?

Overview was fixed by removing luci-app-ddns, at least is showing up. Wiregard status is not visible. At least both services (DDNS and Wiregard) are working...

Regards
Weasel

I installed wireguard luci-app-wireguard ddns-scripts and luci-app-ddns. I did notice, though, that the luci-app-ddns would not install due to errors regarding files already part of the base install:

but that file is already provided by package * luci-base

To resolve that issue, I used the --force-overwrite argument and everything worked properly.

My general status page is working properly, as are the other two:
DDNS is found under Services > Dynamic DNS
and Wireguard Status is found under Status > WireGuard Status

I don't have such conflict, but immediately after installing luci-app-ddns Overview becomes unavailable.
Could you show me what luci packages versions you have?

opkg list-installed | grep luci

Regards
Weasel

LuCI versions - default - 19.07.2 fresh install on VM
liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
luci - git-20.057.55219-13dd17f-1
luci-app-firewall - git-20.057.55219-13dd17f-1
luci-app-opkg - git-20.057.55219-13dd17f-1
luci-base - git-20.057.55219-13dd17f-1
luci-lib-ip - git-20.057.55219-13dd17f-1
luci-lib-jsonc - git-20.057.55219-13dd17f-1
luci-lib-nixio - git-20.057.55219-13dd17f-1
luci-mod-admin-full - git-20.057.55219-13dd17f-1
luci-mod-network - git-20.057.55219-13dd17f-1
luci-mod-status - git-20.057.55219-13dd17f-1
luci-mod-system - git-20.057.55219-13dd17f-1
luci-proto-ipv6 - git-20.057.55219-13dd17f-1
luci-proto-ppp - git-20.057.55219-13dd17f-1
luci-theme-bootstrap - git-20.057.55219-13dd17f-1
rpcd-mod-luci - 20191114

opkg install --force-overwrite wireguard luci-app-wireguard ddns-scripts luci-app-ddns

LuCI versions post-install
liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
luci - git-20.057.55219-13dd17f-1
luci-app-ddns - 2.4.9-7
luci-app-firewall - git-20.057.55219-13dd17f-1
luci-app-opkg - git-20.057.55219-13dd17f-1
luci-app-wireguard - git-20.131.47987-bcdb9fd-1
luci-base - git-20.057.55219-13dd17f-1
luci-compat - git-20.131.47987-bcdb9fd-1
luci-lib-ip - git-20.057.55219-13dd17f-1
luci-lib-ipkg - git-20.131.47987-bcdb9fd-1
luci-lib-jsonc - git-20.057.55219-13dd17f-1
luci-lib-nixio - git-20.057.55219-13dd17f-1
luci-mod-admin-full - git-20.057.55219-13dd17f-1
luci-mod-network - git-20.057.55219-13dd17f-1
luci-mod-status - git-20.057.55219-13dd17f-1
luci-mod-system - git-20.057.55219-13dd17f-1
luci-proto-ipv6 - git-20.057.55219-13dd17f-1
luci-proto-ppp - git-20.057.55219-13dd17f-1
luci-proto-wireguard - git-20.131.47987-bcdb9fd-1
luci-theme-bootstrap - git-20.057.55219-13dd17f-1
rpcd-mod-luci - 20191114

There are no differences at all in those versions, except for the addition of 5 lines:

Added lines

luci-app-ddns - 2.4.9-7
luci-app-wireguard - git-20.131.47987-bcdb9fd-1
luci-compat - git-20.131.47987-bcdb9fd-1
luci-lib-ipkg - git-20.131.47987-bcdb9fd-1
luci-proto-wireguard - git-20.131.47987-bcdb9fd-1

Thx!
We have different versions and my opkg install didn't pull luci-compat package
Thats my list (removed luci-app-ddns):

liblucihttp-lua - 2019-07-05-a34a17d5-1
liblucihttp0 - 2019-07-05-a34a17d5-1
luci - git-20.057.55219-13dd17f-1
luci-app-firewall - git-20.057.55219-13dd17f-1
luci-app-opkg - git-20.057.55219-13dd17f-1
luci-app-wireguard - git-20.069.54281-3fb8e3d
luci-app-wol - git-20.108.38431-8f34e10
luci-base - git-20.057.55219-13dd17f-1
luci-lib-ip - git-20.057.55219-13dd17f-1
luci-lib-ipkg - git-20.069.54281-3fb8e3d
luci-lib-jsonc - git-20.057.55219-13dd17f-1
luci-lib-nixio - git-20.057.55219-13dd17f-1
luci-mod-admin-full - git-20.057.55219-13dd17f-1
luci-mod-network - git-20.057.55219-13dd17f-1
luci-mod-status - git-20.057.55219-13dd17f-1
luci-mod-system - git-20.057.55219-13dd17f-1
luci-proto-ipv6 - git-20.057.55219-13dd17f-1
luci-proto-ppp - git-20.057.55219-13dd17f-1
luci-proto-wireguard - git-20.069.54281-3fb8e3d
luci-theme-bootstrap - git-20.057.55219-13dd17f-1
rpcd-mod-luci - 20191114

Are we using same target repository? Mine below:

src/gz openwrt_core http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/packages
src/gz openwrt_kmods http://downloads.openwrt.org/releases/19.07.2/targets/ipq40xx/generic/kmods/4.14.171-1-fa00c1231ac7d7840ec6ffe62dcad926
src/gz openwrt_base http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/19.07.2/packages/arm_cortex-a7_neon-vfpv4/telephony

PS. I see repository was updated today Wed May 13 and luci packages are i.e.
luci-base_git-20.131.47987-bcdb9fd-1_arm_cortex-a7_neon-vfpv4.ipk

PS2. Forum limited my replays, so editing current post
OK
Finally I put router back to work. 13 May morning repository update sorted problem with luci packages.
I did upgraded all luci packages, my guess was to avoid conflict between luci-base and luci-compat. Just reboot after upgrade, otherwise menu-bar disappeared.

Then installed what i was missing so
luci-app-wireguard
luci-proto-wireguard
luci-app-ddns
luci-app-fwknopd
luci-app-upnp

Regards
Rafał

My feeds are the defaults from the 19.07.2 stable release, but on x86 (I've setup a VM for testing purposes)

src/gz openwrt_core http://downloads.openwrt.org/releases/19.07.2/targets/x86/64/packages
src/gz openwrt_base http://downloads.openwrt.org/releases/19.07.2/packages/x86_64/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/19.07.2/packages/x86_64/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/19.07.2/packages/x86_64/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/19.07.2/packages/x86_64/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/19.07.2/packages/x86_64/telephony
1 Like