Large UDP packets not getting routed

I have a Ubiquiti router running OpenWrt router version 21.02.3. The router's wlan0 and lan0 are bridged.

I have a weird problem, but first let me give some background:
I have a small robot that sends status messages and camera images (mjpeg) via UDP to a PC (separate ports for status and images).

When both PC and robot are connected to the router via wifi, the PC receives both status messages and images without problems.
Both are on 192.168.0.x ip address space.

Now comes the problem:
Instead of the PC being connected to the wifi, I am using a raspberry pi to connect to the wifi, and is connected to the PC via eth0, but on another subnet (192.168.3.x).

I have setup proper routing rules on the router and the pi, so that one subnet can communicate with the other subnet.

All seems to work well: I can ping the robot with its 192.168.0.x address, from the PC which has 192.168.3.x address.
I can also ping the PC from the robot.

I can also receive the UDP status messages on the PC just like before. These messages are fairly small, around a few hundred bytes.

But, I'm not receiving the images any more...
If I connect the PC to the wifi again, images are received again.

I am using the standard/out of the box firewall settings on the Openwrt, and don't seem to have any rules that should block these ports.

I am trying to troubleshoot this problem, but don't know where to start, or who is at fault here (maybe the raspi? the Openwrt ?).

I am suspecting that maybe this has to do with UDP fragmenting or MTU, but don't know how to check this or how to solve.
Maybe its another issue?

I would really appreciate your help!

Just an idea, but get a packet capture and check the TTL field of the packets that contain images, sometimes the TTL is set to a very low numbers (not sure whether 1 or 2) so that packets get dropped by a router. If that is the case one can try to rewrite the TTL field to something a bit larger. But that is pretty speculative since I have no data implying this would be the case on your link.