Laptop Wifi connects to weakest 5ghz transmitter (dumb ap<router)

Hi again,
my laptop keeps connecting to my router (8 meters away, 1 floor down, several walls).
My dumb ap is on the attic (3 meters away, 1 wall, 1 floor up).
Result is low speed of course.
I could of course disable 5ghz on my router, but I don't want to do that.
Both router and dumb ap are linksys 1900acs running divested firmware.

Any clues what I could do?

Side question; it's preferable to have different channels selected for wifi on router and dumb ap, right?

Easiest way to remedy it would probably be to enable 802.11r Fast Transition on both devices, assuming the wifi driver is capable of it. Don't forget to replace the hostapd with full version.

If you have several devices with lots of traffic, and the router is close to the AP, then having separate channels helps spread the bandwidth.

If you use the same channel, bandwidth is shared, but devices tend to move faster between APs, or choose better.

I would configure both APs on the same channel, and see how it works for you.

@frollic Thanks, I'll read up. My laptop is mostly at my home office so I don't think I need the roaming feature for my laptop, but maybe nice with iphone/ipads that moves around more?

@eduperez There are two floors between router and AP, maybe 7-8meters or so in total. I recently changed the channel on the AP to have it separate, but I can switch back and test. Regarding the DFS channels in europe, best to stay away from those channels right?

Another sidenote, yesterday my 5ghz network crashed on my dumb ap. The 1900acs is a used one I bought recently. I restarted the wireless interface and I think it came back (maybe I did a restart as well), looking at the system log it's 5 minutes with this;

Tue May 18 13:53:48 2021 kern.debug kernel: [147697.083000] ieee80211 phy1: Mac80211 start BA 08:xx:xx:xx:xx

I can't really say that this has been a issue on my 1900acs router tho, I've had that one for 3-4 years.

Yes, but it should roam to the strongest signal, and not stay with your other AP, if you configure 802.11r, and you wouldn't experience any temp dropouts if the 1900 freeze/reboot.

At least that's what I've seen, but I'm using Archer C2600s :wink:

OK. I'm looking at the reddit guide, am I correct that this is all I have to do to make FT work?

All this is availably via LuCI, go to "Wireless Security", enable "802.11r Fast Transition", enable "Generate PMK locally", that should be it. Unfortunately I lack the time and hardware to really test this

Further in the guide there is more configuration stuff so I'm prepared to try that as well.

Enable / fill in the fields as in the pic, replace hostapd.

That's all I did, and it works really well.

Didn't do all that, might have gotten added after I had set up mine.

Ok, install hostapd and overwrite files?

hostapd	2020-06-08-5a8b3662-32	367.4 KB	This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS…

Divested firmware already include

hostapd-common	2020-06-08-5a8b3662-32	11.6 KB	hostapd/wpa_supplicant common support files

edit; divested developer states this on their website;

Why make these builds? * I need wpad-full compiled in for RADIUS support.

then you probably don't need it to swap it out.

Tried with the same numbers as you for both router and ap, but not sure if it works. Read a little and the reddit guide is old, seems like all that is needed is to activate 802.11r.
But then again I don't see any difference with my laptop still connecting to the router instead of ap.
Running both on the same channel for now.
Does the 1900acs support 802.11r?

That's the part I'm unsure of, different radios, compared to my devices ....

I assume your 1900s have the same SSID and pwd ?

If you have an Android device, install Wifi Analyzer - https://play.google.com/store/apps/details?id=com.vrem.wifianalyzer&hl=en&gl=US . In the list of the found WiFis select yours, to get a popup with details.

You want to see the FT listed as capability/attribute.

Same ssid and pwd yes.
Only iphones in this house I'm afraid! Got to be a wifi analyzer for iphone too

not sure if IOS allows that kind of activity within user space ... :wink:

A Windows wifi analyzer then :slight_smile:
@frollic tried optioin log_level '1' on wireless config and walked around with my iphone. no indication that FT was working in the logs. Think I spent enough time on this now to let it rest.. :slight_smile:

Increasing the basic rate will make it impossible for clients to use an AP unless the signal is strong. This tends to steer clients to a nearby AP as the only one they can work.

Snapshot has the cell_density option. Older builds can do something similar by directly setting a rate:

        option supported_rates '54000'
        option basic_rate '54000'

This goes in the wifi_device section, so unfortunately you can't set it per interface, it applies to all interfaces on the radio.