Laptop connecting to weaker access point

I recently set up a new Linksys E8450 with OpenWRT. I also have several TP-Link AC1750s around my house. All of the access points are configured essentially identically, except for being on different channels and one set for DHCP (and the AC1750s are running a version of OpenWRT that's a few years older). They are all set for 80 MHz on either channel 36 or 153.

The problem is that my laptop is not connecting to the Linksys E8450, which is by far the strongest signal. The laptop will keep connecting to one of the AC1750s with a downlink/uplink of ~60/90 Mbps. When I disable the AP its connecting to by default, it will connect to the E8450 with a downlink/uplink of ~1,000/1,000 Mbps. Any ideas on why that might be happening?

On a possibly unrelated note, when I tried to troubleshoot this issue, I tried changing the E8450 from channel 36 to channel 153. But I cannot set it to channels above 144.

An often overlooked tuning parameter is the power of the radios in each AP. The power should be reduced to encourage devices to roam.

I like the way this video describes the tuning process:

Thanks for the response. I turned the signal down on the AP it was connecting to by 5 dB, and that seems to have solved my issue.

I also realized the issue for trying to set my E8450 to channel 153--I needed to set my country code to US. That also explains why I could never get DFS working! I now have 5 APs all on non-overlapping 80 MHz channels (with one 160 MHz)!

great. (although I'd recommend not using 160MHz for a variety of reasons).

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile: