LAN stops working every now and then

So. I used the latest tp-link "portugal" firmware for more than a week now... and had no issues, lan/wan stops whatsoever with it. Seems like it's a firmware issue after all (If it stays stable for a month, then I'll use it permanently). :slight_smile:

But how does it affect LEDE then?
Would you mind trying to flash LEDE onto your device after sometime to check if the issue has been resolved there too? Maybe there was an issue with u-boot or something?

I'm thinking of a kernel-patch, or some device-driver fixes (tp-link uses the same gnu-tools, daemons as lede/*wrt according to the log entrys).

I had an issue when I installed a brand new v4 with Lede in a datacenter as a firewall between the servers and the rest of the network.
With default settings it did not pass any traffic towards the wan port (if I remember correctly, RX packet counter was growing but TX wasn't - or maybe the other way around).
Anyway, after lowering MTU to 1400, it immediately started working properly.
Maybe you could give that a try.

How do I lower MTU in LEDE?

config interface wan
        option ifname    'eth0.2'
        option proto     'static'
        option mtu       '1400'
        list ipaddr      'xxx/24'
        list ipaddr      'yyy/32'
        option gateway   'zzz'
        list dns         'aaa'
        list dns         'bbb'
  1. Do you maybe use any USB devices with your v4?
  2. Do you maybe use SQM/QoS?
  3. How fast is your Internet connection?

Also do you think you could try at some point LEDE 17.01.1 (or soon to be relased 17.01.2) after flashing the Portugal firmware? I wonder if the Portugal firmware made some changes that fixed some parts of flash memory that the LEDE wasn't touching. I would try this myself but I don't have access to my v4 for now.

Everyone who's having this issue please add you vote here, in the bug report.
Thank you.

On my 17.01.1, a71xx based build I was having similiar events where my static connection became unresponsive, including pings to and the router itself On OpenBSD, if I took down my network connection and restarted it, the connection would be restored.

I was not using IVP6 and I disabled all the IVP6 check boxes I could find in luci. At the same time I specified dns servers per @mike advice here. I have not had an unresponsive connection in 3 days. I think the improvement is likely due to IVP6 and if others can replicate, it should help identify the problem.

I was using OpenWrt Chaos Calmer 15.05.1 on TP-Link TL-WR1043N/ND v2 for a long time. Since LEDE is a successor of OpenWRT I tried the latest stable build LEDE 17.01.2 and almost immediately got this bug. Built-in switch fails about every 10 minutes with all Ethernet ports. So no WAN connection, no LAN connection, the only way is to reload switch configuration through wi-fi or power cycle the whole device.

OpenWRT on WR1043NDv4 doesn't really work. There is no 15.05.1 release, only trunk.

Can you try flashing original firmware but portugal version and then LEDE?
Can you also provide a list of custom packages you installed onto the router? I never got a fail of switch so soon after flashing LEDE.

In followup, My static NIC connections would become unresponsive on a daily basis. When I disabled IPV6 and manually set my WAN dns servers the problem went away. I have not had an unresponsive connection in over 2 weeks. Running 17.01.2/ar71xx on a Trendnet TEW-732BR.

I'm talking about TL-WR1043Nv2, v3 and TL-WR1045N, they have some hardware differences from TL-WR1043Nv4 and they are supported by OpenWRT 15.05.1 release which works well.

Packages in overlay:

For DNS I actually use DNSCrypt-Proxy.
I'm not sure if it's possible to set it up manually for WAN interface.

I was given the following in another thread

@r43k3n Have you ever tried disabling IPv6?

No, I haven't
I wouldn't know where to start.

About disabling IPv6:

Because you use it too extensively, or because you haven't yet thought about using any major search engine? Leading to e.g.

Because I haven't actually thought about disabling it, nor did I need to search for information about how to do it. I don't have the router anymore and I'm running the OpenWRT 15.05.1 on an older unit. No problem there.

@pita @r43k3n pita's problem happen to me to. and ping ip address not work too.