LAN stops working every now and then


#15

Yes, the stock TP-Link firmware seems a bit more stable for me (used it for a month with only 3-4 LAN-lockups). After disabling every feature I could (IPv6, firewall, wifi...),and the problem still persisted I moved to OpenWRT (then LEDE). Actually I found one guy at the Opewrt forums with the same issue. TP-Link got his router replaced, but that did not solve his problem. Someone said, that this also could be a traffic-related problem (weird ISP configuration, oversized packets...), or the problem is in the u-boot section which is not replaced by custom firmware. I try to experiment with it in the weekend.
We used V3-s at work, and they were rock-solid, thats why I choose this box. I hope the problem can be solved in software.


#16

If the problem is also present on factory firmware then I don't know what else there is to do. I actually was able to to run the router for 28 days without incident when I initially installed LEDE. Right now I'm unable to get more then 3 days without WAN/LAN hangs. I also got the unit replaced and this also didn't solve the issue for me. The weird thing is that the logs and dmesg are perfectly clean. In my case there isn't a single entry reflecting the issue. I wrote a script that checks every 5 minutes if the internet is working and then restarts the network when WAN/LAN hangs.

About the traffic-related problem you mentioned. I don't think it the problem with the ISP. My cable modem runs in modem mode, which means that the LEDE router is doing all the work. I also had the same ISP, same modem and same config on v1 and I didn't had this issue there.

You also mentioned u-boot section. I'm not sure what this has to do with the problem since firstly the problem also occurs on the TP-Link firmware and secondly once the LEDE boots, u-boot has nothing else to do. I don't think replacing u-boot sections is a standard practise when installing LEDE, but I might be wrong. Maybe @jow or @hnyman can clarify this.

Did you maybe tried to contact TP-Link support regarding this issue?


#17

Maybe try replacing the power supply if you happen to have a suitable replacement chord available.


#18

My replacement unit came with a new power supply.
I also don't think the power supply changed since HW2.1 and every thing worked fine there.

I'm thinking about returning the router to the store as a faulty model. BTW TP-Link still didn't fixed the NAT leakage problem so I can use this as a base cause if the store will try to make troubles for me (which would be illegal for them to do so).


#19

Can you maybe share a link to the thread you mentioned?


#20

It was Gluon, sorry (but it's based on OpenWRT too):
https://github.com/freifunk-gluon/gluon/issues/1101


#21

I saw you created this bug report:
https://github.com/openwrt/openwrt/issues/472

You might want to file it here though, since OpenWRT is pretty much dead and LEDE is it's successor.
https://bugs.lede-project.org/


#22

Oh geez, i have same problem with mine too. Link is on but no traffic :neutral_face:


#23

Bugreport sent:
https://bugs.lede-project.org/index.php?do=details&task_id=794

Also I posted it to official TP-link forums (post awaits admin permission):
http://forum.tp-link.com/forumdisplay.php?39-300Mbps-amp-450Mbps-Wireless-Routers

I try to contact TP-link support after that, although they did not respond to my prev. request.


#24

As more people report the same problem I doubt that the power supply is the cause but the fact that you got a replacement doesn't necessarily rule it out. The same (type of) power supply might behave differently in different circumstances.


#25

I noticed that TP-Link has published a new firmware for WR1043ND v4 for Portugal.
http://www.tp-link.com.pl/download/TL-WR1043ND.html#Firmware

Before anyone will decide to flash it. Make sure it does not have a locked bootloader so you can return to other version if needed.


#26

What do you suggest to try to reproduce this problem?

I got a TL-WR1043ND v4 but in production. Wifi + DHCP turned off. 1 24/7 client running Debian 8. I haven't had any too apparent problems with it (since the NAT leakage was fixed), but I might have missed what you report.


#27

Actually I have no idea. It's always happening at random for me. Usually though at day, when there are three or four computers on the network. I actually haven't noticed any "hangs" at night when only the server was running. I have an older PC working as server and pushing data 24/7. I have also a PC machine and two laptops. I noticed that when all of them are in use the "hang" occurs more often. I should probably mention that during the "hang" I always had at least two computers connected via Ethernet cable.

There was one incident, 28 days after the first LEDE install, coming from factory firmware. It was 2 am, only server was working, my brother connected his laptop via Ethernet and shortly after the hang occurred.

Do you have any script or something that restarts your network when Internet fails?
I do. I have had it write a log message to my USB so I knew then the restart occurs.

Well, I also have this issue with my setup. I don't know if this is connected. I replaced the Ethernet cable and reinstalled the OS on computer. It didn't solve the issue. I've never had this problem on v1.


#28

I forgot that I have a 2nd 24/7 client attached to the LAN ports. My own PC :wink:
Installed SmokePing now. Maybe this will show something.


#29

Did you got any response?

I received an e-mail from TP-Link Poland, Tech Department. I won't be publishing the content of the e-mail because it's in Polish but they asked if I ever used those options "IP & Mac Binding" or "DoS Protection" in Advanced>Advanced Security tab. Well, I didn't. Did any of you used them?

I don't think they understand that OpenWRT and LEDE also shows this issue. It's funny because I believe that the official firmware is based on OpenWRT Altitude Adjustment.


#30

I did.
They said the unit probably has a hardware failure, and I should return it.
I did not touch those settings you mentioned (both are disabled by default).
For now I installed the newest TP-Link "portugal" firmware: 3.17.9 Build 20170401 Rel.64459n (also shows up if you choose Germany under regions), and waiting for the problem to occur.


#31

That's funny since there are now 4 or 5 people with the same issues across Europe. Did you pointed that out to them? May I ask from which country are you from and which TP-Link (Tech Department?) gave you that response?

@andreas asked before if I know how to reproduce this problem. Do you maybe have anything to add to what I already said?

Out of curiosity. How do you recover from the WAN/LAN "hang" on official firmware?


#32

I know, and the replacement unit they got in return suffers from the same issue as I heard. Also I sent them the links for this forum threads, and the one I opened on tp-link forums:
http://forum.tp-link.com/showthread.php?97391-TL-WR1043ND-v4-LAN-WAN-ports-stop-working
For now I take my time with the return, maybe we/they can find a solution, or until they come out with v4-rev.2 hardware (which I probably will get as a replacement then :slight_smile: ). Btw I'm from Hungary.
I really don't know how to reproduce the problem, seems pretty random to me (maybe depends on connection count?: torrents, multiple clients...)

Thats a good question :slight_smile:
I go to the box, and press the reset button.


Archer C7v2 loses LAN connectivity randomly
#33

I have exactly same issue on my 2 TP-LINK Archer C7 AC1750 (CA) version routers. The freeze happened at the time when another device was joining the network either via WIFI or via cable. When it happened all the devices were shut off internet connection. (I have 4 devices connected to the router). The devices were pingable, still have access to the router, just didn't have access to the internet. Waiting 10-20 minutes the route would come back to life, then the internet connections came back to all the devices. syslog, dmesg were clean.

When it happens browsers return DNS error for well known websites (e.g. www.google.com)
I suspected hostapd+hdcpd+dnsmasq caused the issue.

The issue happened on 2 identical boxes. so It either has design defects on the power supplier or power supplier is not related to the issue.


#34

That doesn't seem exactly like the problem I'm having. You see I can't ping router or other devices if I'm connected via Ethernet. I also can't get IP on WAN interface and can't get IP from DHCP client. The WiFi is working fine, I can ping other devices (not the Ethernet one), access router though SSH etc.

I don't think my router ever recovered but I couldn't afford to wait 20 minutes to get my network back online.

Do you use DNSCrypt-Proxy?