LAN performance issues

Hello

I have a Raspberry Pi 4B serving as router and a NetGear WAX202 as AP (both with OpenWRT)
The RPi is connected to the ISP modem (in bridge mode) via a TP Link UE300 USB dongle (gigabit).
The AP connects to the RPi's RJ45 port.

So..... At the modem, speedtest gets > 300mbit/s results for downloads.
Speedtest-cli at the router gives me 150-200mbit/s downloads. I have a Wireguard client in the router which could explain the difference, but the RPi4B was supposed to handle 300mbit/s for what I've heard.
Sppedtest-cli at the AP gives me no more than ~50mbit/s.

But the worst part is that on occasion it seems like the LAN is under a DDoS attack.
Speedtests at the router are still pretty high, but AP or clients can't get more than 1 or 2 mbit/s.
Before upgrading to 24.10 at the router I had a similar setup, but with OpenVPN, and even though throughput was limited to ~30mbit/s, I never had any such periods of such painful performance. Apart from the openvpn -> wireguard upgrade, nothing has changed in the configurations.

Also I changed the previous cat5e cables with cat6 cables not expecting any results (other than 30cm /~1ft long cables looking much better), but I've got some 60mbit/s reads in the AP since.
iperf3 between router and AP gives me ~600mbit/s (with either cable).

Any ideas? I don't even know where to begin troubleshooting from here.

Anyway, here are my config files:

MODEM

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipv6 '0'
	option delegate '0'
	list dns '10.2.0.1'

config interface 'WAN'
	option proto 'dhcp'
	option device 'eth1'
	option peerdns '0'
	list dns '10.64.0.1'
	option ipv6 '0'

config interface 'wg0'
	option proto 'wireguard'
	option private_key '          '
	list addresses '10.2.0.2/32'
	list dns '10.2.0.1'
	option mtu '1400'

config wireguard_wg0
	option description 'Imported peer configuration'
	option public_key '               '
	list allowed_ips '0.0.0.0/0'
	option endpoint_host '               '
	option endpoint_port '51820'
	option route_allowed_ips '1'

dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

WAX202 AP

network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd47:ddf0:f033::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

config device
	option name 'lan1'
	option macaddr '34:98:b5:11:19:11'

config device
	option name 'lan2'
	option macaddr '34:98:b5:11:19:11'

config device
	option name 'lan3'
	option macaddr '34:98:b5:11:19:11'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.10.3'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.10.1'

config device
	option name 'wan'
	option macaddr '34:98:b5:11:19:12'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'