LAN IP change gets rolled back on D-Link DAP-2695

I am running in an issue that might be a bug.
I have tried several times.
When changing the LAN IP from default to a custom, it constantly roll back to default.
I have reset the DAP a few times and I have the same result using Luci.
If I modify the /etc/config network and modify the config interface 'lan' accordingly, than my new IP is set for the LAN.
for those with more expertise: am I doing something wrong or there is a bug here?
I run other openwrt devices and the procedure always worked.
Openwrt version: openwrt-21.02.1-ath79-generic-dlink_dap-2695-a1-squashfs-factory

There's usually a timeout, and a 2nd popup when changing the subnet, saying something like Apply unchecked.


actually out of the few test I made, only one time I saw that popup!
I will look at it again as I had reset it again.
modifying the network config file there seems not to be any issues

doing it using vi or uci shouldn't make any differance.

1 Like

I confirm that the the " Apply unchecked " do not show up anymore.
Moreover, almost any change I want to do is not applied.
It is now complicated to use Luci and I dont have enough knowledge to use CLI for all changes I need to do.
Do we have some experience with DAP-2695?
I really would love to use this device.

I kind of running out of options... Any idea?

do you know where I can download previews version (19) ?
I want to test is V. 19.x works better in applying changes.

uci set network.lan.ipaddr='aaa.bbb.ccc.ddd'
uci commit network
/etc/init.d/network restart

1 Like

Turned out the change of IP is not the only issues.
I am configuring a dumb AP and all changes and vlans I create to match the main router, dont get committed and roll back with no option of apply anyway!
I found the FW selector. Really nicely made from openwrt. I will apply and see if it de-block the all issue after re-ugrading to latest again.

Create a new SSID for management and connect to this wifi SSID to perform the changes. This way your connection will not be affected by vlan or other interface changes.

1 Like

you mean that by creating a new SSID and do all needed configuration using that management SSID, should solve my problem and be able to apply all needed configuration without the non-commitment issue?
As soon as I can I will try.
I find this workaround quite interesting..
will certainly check it out

1 Like