LAN-internal connection issues during the first 30 seconds of a connection

Hi,

I've got a weird problem with my Fritz!Box-OpenWRT-Accesspoint I dont know how to debug.

As a background: I'm using a Fritzbox 7530 with FritzOS as my main router <-LAN-> a Fritzbox 4040 with FritzOS as an AP <-LAN-> TP-Link 8-Port-Switch <-LAN-> Fritzbox 4040 with OpenWRT 22.03.0 as an AP. I've created a simple network plan I'll attach below.

I configured the OWRT-device according to the https://openwrt.org/docs/guide-user/network/wifi/dumbap guide.

The behaviour I'd like to debug is the following:
When I move from the 5Ghz Wifi of the FritzOS-FB4040 to the 5Ghz Wifi of the OWRT-FB4040 (different SSIDs) I don't have access to any LAN-IP-Adresses except for the IP / Webinterface of the OWRT-FB4040 for approx. the first 30 seconds. It is only this way, not the other way around. When I move back to the wifi of the FritzOS-FB4040, everything is reachable immediately as expected. During this period of time internet access seems to work perfectly. After around 30 seconds LAN access also works as expected. I was able to reproduce this behaviour with two different devices (linux-laptop and android-smartphone) several times.
I wasn't able to reproduce it when connectig the laptop via ethernet instead of wifi.

Below I'll paste the contents of /etc/conf/network and /etc/conf/wireless.


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '[redacted]'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config interface 'wan'
	option device 'eth1'
	option auto '0'
	option proto 'none'

config interface 'wan6'
	option device 'eth1'
	option auto '0'
	option proto 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0'
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option band '2g'
	option cell_density '0'
	option htmode 'HT40'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '[redacted]'
	option encryption 'sae-mixed'
	option key '[redacted]'
	option disassoc_low_ack '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option channel 'auto'
	option channels '36-128'
	option country 'DE'
	option log_level '2'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key '[redacted]'
	option ssid '[redacted]'
	option encryption 'sae-mixed'

Where would be the right place to look for the cause of this behaviour?
If more / other information is needed please ask for it.
Your help is very much appreciated, as is the creation and maintaining of OpenWRT.