LAN host can't ping outside, but router can

Hi,

I have installed 22.03 and I can ping openwrt.org from the router like the wiki docs say. However, I cannot ping or access the internet from the machine behind the router.

This router is behind a firewall which doesn't allow me to install a vpn client, so I am doing this for the purpose of installing VPN on OpenWRT router.

One thing I notice is that when I type route on the host machine, it takes about 10 seconds for each entry to come up.

It would appear DNS is not working correctly from the host behind the router. I do have ip forwarding set on the host and it looks like I have a route in the table.

Thoughts?

Info ...

(wan) FW (lan) <- 192.168.20.0 -> (wan) OpenWRT (lan) <- 192.168.120.0 -> host

On host:

$ ifconfig
br0: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        inet 192.168.120.10  netmask 255.255.255.0  broadcast 192.168.120.255
        inet6 fdca:57b1:ab19:0:d0ba:e6ff:fe6f:d04  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::d0ba:e6ff:fe6f:d04  prefixlen 64  scopeid 0x20<link>
        ether d2:ba:e6:6f:0d:04  txqueuelen 1000  (Ethernet)
        RX packets 1  bytes 160 (160.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13  bytes 950 (950.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:ad:30:87:a9  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.20.10  netmask 255.255.255.0  broadcast 192.168.20.255
        inet6 fe80::96de:80ff:feb4:7cc6  prefixlen 64  scopeid 0x20<link>
        inet6 fdca:57b1:ab19:0:96de:80ff:feb4:7cc6  prefixlen 64  scopeid 0x0<global>
        ether 94:de:80:b4:7c:c6  txqueuelen 1000  (Ethernet)
        RX packets 2164757  bytes 2000461553 (1.8 GiB)
        RX errors 1  dropped 0  overruns 0  frame 1
        TX packets 1176227  bytes 163266626 (155.7 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf3100000-f3120000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 31334  bytes 2485195 (2.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 31334  bytes 2485195 (2.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 16:9e:af:b6:48:0f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b2:ed:96:b4:8c:6e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
$ ip route
default via 192.168.120.1 dev br0 metric 24 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
192.168.20.0/24 dev eno1 proto kernel scope link src 192.168.20.10 
192.168.120.0/24 dev br0 proto kernel scope link src 192.168.120.10 
192.168.120.0/24 via 192.168.120.1 dev br0 metric 24

On router:

# ip route
default via 192.168.20.1 dev wan  src 192.168.20.100 
192.168.20.0/24 dev wan scope link  src 192.168.20.100 
192.168.120.0/24 dev br-lan scope link  src 192.168.120.2
# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdca:57b1:ab19::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option gateway '192.168.120.1'
        option broadcast '192.168.120.255'
        list ipaddr '192.168.120.2/24'

config device
        option name 'wan'
        option macaddr '62:38:e0:c0:b5:90'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

$ ifconfig
br-lan    Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          inet addr:192.168.120.2  Bcast:192.168.120.255  Mask:255.255.255.0
          inet6 addr: fe80::6238:e0ff:fec0:b590/64 Scope:Link
          inet6 addr: fdca:57b1:ab19::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:51760 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47439 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5110394 (4.8 MiB)  TX bytes:49367245 (47.0 MiB)

eth0      Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          inet6 addr: fe80::6238:e0ff:fec0:b590/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1508  Metric:1
          RX packets:54535 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48987 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1024 
          RX bytes:9120533 (8.6 MiB)  TX bytes:49929829 (47.6 MiB)
          Interrupt:45 

lan1      Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan2      Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lan3      Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:51845 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47439 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5114814 (4.8 MiB)  TX bytes:49367245 (47.0 MiB)

lan4      Link encap:Ethernet  HWaddr 60:38:E0:C0:B5:90  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13099 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13099 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:997697 (974.3 KiB)  TX bytes:997697 (974.3 KiB)

wan       Link encap:Ethernet  HWaddr 62:38:E0:C0:B5:90  
          inet addr:192.168.20.100  Bcast:192.168.20.255  Mask:255.255.255.0
          inet6 addr: fe80::6038:e0ff:fec0:b590/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2690 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1530 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2805949 (2.6 MiB)  TX bytes:168960 (165.0 KiB)

It appears that you have the same subnet defined for the OpenWrt LAN as is present on the upstream connection (i.e. the OpenWrt WAN).

In order for routing to work properly, you must use a different subnet on the WAN vs LAN. You could change your LAN to something else (for example: 192.168.2.0/24 with the router at 192.168.2.1)

The subnet between the firewall and openwrt is 192.168.20.0 and the subnet on the openwrt LAN is 192.168.120.0`. OpenWRT gets it's WAN interface via DHCP. That's the 192.168.20.100.

The LAN interfaces behind openwrt are set statically in the 192.168.120.0/24 range.

I took a second look after your comment and do see 192.168.20.10 on my eno1 interface, that can't be right so trying to fix that now.

oh... my bad. I misread (120 vs 20)..

What does the firewall look like (cat /etc/config/firewall)?

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
	option name		Support-UDP-Traceroute
	option src		wan
	option dest_port	33434:33689
	option proto		udp
	option family		ipv4
	option target		REJECT
	option enabled		false

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

remove the gateway from the lan interface. It should actually just default to the system gateway.

I removed the line option gateway '192.168.120.1' and rebooted, no change. Host machine still can't ping 8.8.8.8 nor browse.

let's take a look at all the config files (including the ones you already shared -- updated copies):

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
# cat network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdca:57b1:bb29::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        option broadcast '192.168.120.255'
        list ipaddr '192.168.120.2/24'

config device
        option name 'wan'
        option macaddr '62:38:e0:c0:c5:90'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '60:38:e0:c0:bb:92'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr '60:38:e0:c0:bb:91'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
# cat dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
# cat firewall

config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
	option name		Support-UDP-Traceroute
	option src		wan
	option dest_port	33434:33689
	option proto		udp
	option family		ipv4
	option target		REJECT
	option enabled		false

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
``

I’m not seeing any issues. What do the client devices have for their ip address info (complete with subnet mask, router/gateway, and dns)?

This is all on the host machine which is sitting on the openwrt LAN.

$ ifconfig
br0: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        inet 192.168.120.10  netmask 255.255.255.0  broadcast 192.168.120.255
        inet6 fdca:57b1:ab19:0:d11a:e4ff:fe3f:d04  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::d0ba:e6ee:fe7f:d04  prefixlen 64  scopeid 0x20<link>
        ether d2:ba:e6:6f:1d:03  txqueuelen 1000  (Ethernet)
        RX packets 14215  bytes 8778315 (8.3 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 16622  bytes 2195823 (2.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

docker0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 172.17.0.1  netmask 255.255.0.0  broadcast 172.17.255.255
        ether 02:42:ad:30:87:a9  txqueuelen 0  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.20.10  netmask 255.255.255.0  broadcast 192.168.20.255
        inet6 fe80::96de:80ff:fec3:7bb6  prefixlen 64  scopeid 0x20<link>
        inet6 fdca:57b1:ab19:0:96de:80e:fecc:7ee6  prefixlen 64  scopeid 0x0<global>
        ether 94:de:80:b4:cc:bb  txqueuelen 1000  (Ethernet)
        RX packets 2180526  bytes 2009604506 (1.8 GiB)
        RX errors 1  dropped 0  overruns 0  frame 1
        TX packets 1193029  bytes 165573523 (157.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf3100000-f3120000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 33581  bytes 2701194 (2.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 33581  bytes 2701194 (2.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 16:9e:af:ce:43:0f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tap1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b2:ed:96:b4:33:6e  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
$ cat /etc/conf.d/net

tuntap_tap0="tap"
config_tap0="null"

tuntap_tap1="tap"
config_tap1="null"

tunctl_tap0="-t tap0 -u me"
tunctl_tap1="-t tap1 -u me"

config_eno1="null"

bridge_br0="eno1 tap0 tap1"

# bridge static config
config_br0="192.168.120.10/24"
routes_br0="192.168.120.0/24 via 192.168.120.1 
    default via 192.168.120.1"

dns_servers_br0="8.8.8.8 8.8.4.4"

bridge_forward_delay_br0=0
bridge_hello_time_br0=1000
bridge_stp_state_br0=0

depend_br0() {
    need net.eno1
    need net.tap0
    need net.tap1
}
$ cat /etc/resolv.conf 

# Generated by netifrc for interface br0
nameserver 8.8.8.8
nameserver 8.8.4.4
$ ip route

default via 192.168.120.1 dev br0 metric 24 
172.17.0.0/16 dev docker0 proto kernel scope link src 172.17.0.1 linkdown 
192.168.20.0/24 dev eno1 proto kernel scope link src 192.168.20.10 
192.168.120.0/24 dev br0 proto kernel scope link src 192.168.120.10 
192.168.120.0/24 via 192.168.120.1 dev br0 metric 24 

This is wrong. Your ip address on the openwrt router is currently 192.168.120.2.

You could change it to .1 if that is available and the intent of your network. Or you need to find out why the host(s) behind your router are trying to use the wrong gateway address. Maybe try restarting that host.

The 192.168.120.2 is what I hit to get into Luci. The 192.168.120.1 is the WAN interface for this router. Nothing changed, but I need to play with this a bit more on my host side after setting it to 192.168.120.1.

I thought you said that the wan interface was in 192.168.20.0/24. The wan address is not relevant for the hosts behind your router. Only the router’s lan address is important.

You're right, that last post is wrong. I've been at this a while. I have 192.168.120.1 as the gateway address configured on the OpenWRT LAN. And 192.168.120.2 is what I hit for the OpenWRT pages. I will restart things as I just make a fix to eno which didn't get restarted before, I only restarted br0.

According to your config files, 192.168.120.2 is the only address for the openwrt device on its lan.

Typically, the address used for admin is the same as the gateway address for your lan hosts.

Really, thanks for your help. Unfortunately, other stuff is now going wrong and my batteries on this machine just died. I'll have to pick this up tomorrow, but I thank you much.

No problem. Try another host and things should work

Also, how did the routes get defined in the host you shared?

Ugh, I have no idea why I was thinking that was ok. Changed the LAN IP to .1 and all is well. Once again, thanks for your help. And yeah, before I did the OpenWRT upgrade, other hosts worked fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.