LAN devices lost connection to internet

This is my setup
OpenWrt 18.06 on Raspberry Pi 3B.
Default installation plus Adblock and fail2ban.
On the lan I have couple RPi’s dedicated for its task (web server, Vpn, Domoticz, 3cx pbx, syslog).

Everything was working fine for few month since I switch from Cisco ASA to OpenWrt.

This morning all devices on the Lan lost connection with internet. No I didn’t make any changes last night.
Disabling Adblock didn’t help.
I thought it was dns, tried typing known IP address into web browser and it didn’t connect.
However my web server was accessible from outside.
I could connect from outside to VPN and ssh into any server, but web access didn’t work
Also diagnostics from openwrt (ping, traceroute all worked)

Update: loaded a month old backup and everything is back to normal.
Any idea what could have caused it. Are there any logs besides system and kernel log

Logs are lost after reboot, unless you upload them to syslog server.
Maybe the NAT went off, since router had access, but not the devices connected to the LAN.