KuWfi 4G LTE router upgrade

Just bought this from aliexpress.
It just works, but I would like some more features (like ip reservation).
It has an old version of OpenWrt on top of a QCA9533 V1 processor.
Web interface is working fine, but I didn't succeed to login with SSH

Is it possibile to achieve something on iT?
Thanks in advance
Carlo
system startup...

[    0.000000] Linux version 4.9.214 (hwh@debian10) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7989-82fbd85747) ) #0 Thu Feb 27 21:25:59 2020
[    0.000000] MyLoader: sysp=c09470cc, boardp=69a4f35c, parts=61df91f2
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Qualcomm Atheros QCA9533 ver 1 rev 1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] On node 0 totalpages: 32768
[    0.000000] free_area_init_node: node 0, pgdat 804746d4, node_mem_map 81000020
[    0.000000]   Normal zone: 256 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 32768 pages, LIFO batch:7
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  board=db3 console=ttyS0,115200 mtdparts=spi0.0:128k(u-boot)ro,64k(u-boot-env),128k(config),14528k(rootfs),1472k(kernel),64k(art),16000k@0x50000(firmware) rootfstype=squashfs noinitrd
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 124816K/131072K available (3208K kernel code, 171K rwdata, 800K rodata, 292K init, 205K bss, 6256K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Clocks: CPU:650.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 5880801374 ns
[    0.000009] sched_clock: 32 bits at 325MHz, resolution 3ns, wraps every 6607641598ns
[    0.008888] Calibrating delay loop... 432.53 BogoMIPS (lpj=2162688)
[    0.071956] pid_max: default: 32768 minimum: 301
[    0.077319] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.084826] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.096080] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.107312] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.114916] NET: Registered protocol family 16
[    0.121675] MIPS: machine is db3
[    0.606436] registering PCI controller with io_map_base unset
[    0.629306] PCI host bridge to bus 0000:00
[    0.634063] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff]
[    0.641860] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.648188] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.655884] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.664913] pci 0000:00:00.0: [168c:0050] type 00 class 0x028000
[    0.664960] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    0.665014] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    0.665094] pci 0000:00:00.0: supports D1
[    0.665104] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.665322] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    0.665356] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x101fffff 64bit]
[    0.673669] pci 0000:00:00.0: BAR 6: assigned [mem 0x10200000-0x1020ffff pref]
[    0.681914] pci 0000:00:00.0: using irq 40 for pin 1
[    0.688336] clocksource: Switched to clocksource MIPS
[    0.695321] NET: Registered protocol family 2
[    0.701193] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.709187] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.716412] TCP: Hash tables configured (established 1024 bind 1024)
[    0.723768] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.730451] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.737869] NET: Registered protocol family 1
[    0.742914] PCI: CLS 0 bytes, default 32
[    0.748539] Crashlog allocated RAM at address 0x3f00000
[    0.755855] workingset: timestamp_bits=30 max_order=15 bucket_order=0
[    0.770233] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.776857] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.798819] io scheduler noop registered
[    0.803272] io scheduler deadline registered (default)
[    0.809588] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.817239] console [ttyS0] disabled
[    0.841471] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 1562500) is a 16550A
[    0.851282] console [ttyS0] enabled
[    0.858839] bootconsole [early0] disabled
[    0.871676] m25p80 spi0.0: found w25q128, expected m25p80
[    0.888516] m25p80 spi0.0: w25q128 (16384 Kbytes)
[    0.893459] 7 cmdlinepart partitions found on MTD device spi0.0
[    0.899594] Creating 7 MTD partitions on "spi0.0":
[    0.904551] 0x000000000000-0x000000020000 : "u-boot"
[    0.911982] 0x000000020000-0x000000030000 : "u-boot-env"
[    0.919921] 0x000000030000-0x000000050000 : "config"
[    0.927344] 0x000000050000-0x000000e80000 : "rootfs"
[    0.934363] mtd: device 3 (rootfs) set to be root filesystem
[    0.940352] 1 squashfs-split partitions found on MTD device rootfs
[    0.946746] 0x000000520000-0x000000e80000 : "rootfs_data"
[    0.954779] 0x000000e80000-0x000000ff0000 : "kernel"
[    0.962365] 0x000000ff0000-0x000001000000 : "art"
[    0.969688] 0x000000050000-0x000000ff0000 : "firmware"
[    0.978604] libphy: Fixed MDIO Bus: probed
[    1.008914] libphy: ag71xx_mdio: probed
[    1.640895] ag71xx-mdio.1: Found an AR934X built-in switch
[    1.694303] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    2.331288] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:00 [uid=004dd042, driver=Generic PHY]
[    2.341541] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    2.349845] NET: Registered protocol family 10
[    2.359255] NET: Registered protocol family 17
[    2.364013] 8021q: 802.1Q VLAN Support v1.8
[    2.375675] VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
[    2.385244] Freeing unused kernel memory: 292K
[    2.389877] This architecture does not have kernel memory protection.
[    2.558350] random: fast init done
[    2.966380] init: Console is alive
[    2.970280] init: - watchdog -
[    4.533380] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    4.782805] usbcore: registered new interface driver usbfs
[    4.788668] usbcore: registered new interface driver hub
[    4.794250] usbcore: registered new device driver usb
[    4.806070] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.824058] SCSI subsystem initialized
[    4.833992] ehci-platform: EHCI generic platform driver
[    4.839604] ehci-platform ehci-platform: EHCI Host Controller
[    4.845574] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    4.855893] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    4.888382] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    4.895879] hub 1-0:1.0: USB hub found
[    4.900235] hub 1-0:1.0: 1 port detected

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

@Folini: Did you get an access to the C910 via ssh or telnet? BR Mk_Munich