Kong pro firmware for R7800

And pretty stable?
And no problem to keep setting?

I notice adblock is broken on an upgrade to Kongs latest 17/04 upload. Error shown below on the overview tab. I'm not clever enough to work out what is wrong - hopefully a simple fix - anyone any clues, seen it and fixed it themselves?

Expected ';'
  in https://192.168.0.254/luci-static/resources/view/adblock/overview.js?v=git-20.107.80580-0f8b611:?
  at Anonymous function (https://192.168.0.254/luci-static/resources/luci.js?v=git-20.107.80580-0f8b611:117:14)
  at Anonymous function (https://192.168.0.254/luci-static/resources/promis.min.js?v=git-20.107.80580-0f8b611:3:207)
  at m (https://192.168.0.254/luci-static/resources/promis.min.js?v=git-20.107.80580-0f8b611:2:106)

Update your luci-* and rpcd-packages via opkg package manager.

Thanks for the reply.

Sadly, I think that is beyond me so I'll go back to the previous build and try the next one when it is up. If I go to system>software and 'update lists', the updates list is empty - I presume it points to Kongs repository. If I break something and I lose the internet my family will hound me! :laughing:

I'm in a similar boat as the last few Kong trunk builds send my router into an endless boot loop right after sysupgrade. I can't dedicate time to figuring it out so I tried hnymans latest build and it's working great while maintaining the same configuration + adding Kong's startup script. Can't afford any down time with everyone home right now with this pandemic.

If anybody wants to try hnymans build for R7800, see here:

1 Like

Yep I'm on r12991 working great

I should add i'm not using Trunk, I'm on his 19.07 build. One of the reasons I use the Kong build is familiarity with his ddwrt work but also the testing he puts in. When something isn't working, it's nearly always something my end. As was the case this time. A combination of issues. First issue was that IE suddenly doesn't like the overview page (possibly to do with the js now running client side?). No amount of cache clearing or using in private mode worked. Used Chrome and the display/overview issue was gone. I then had another issue that was solved by clearing out the adblock configuration and starting from scratch. All working well now.

Hello,
I'm having issues with Kong's latest three trunk builds, incl..r13023. Previous versions worked fine.
Constant reboots after a few minutes, mainly wireless issue . Disabling both radios prevents this.

Mon Apr 20 05:26:15 2020 daemon.notice netifd: radio1 (1236): WARNING (wireless_add_process): executable path /usr/sbin/hostapd does not match process  path (/proc/exe)
Mon Apr 20 05:26:15 2020 daemon.notice netifd: radio1 (1236): Command failed: Invalid argument

Clean installing with stock settings or changing defaults (country, beacon interval, etc) doesn't make any difference.

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option channel '161'
	option legacy_rates '0'
	option beacon_int '101'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxx'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxxxxxx'
	option skip_inactivity_poll '1'
	option disassoc_low_ack '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option htmode 'HT20'
	option legacy_rates '0'
	option beacon_int '101'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'xxxxx'
	option encryption 'psk2+ccmp'
	option key 'xxxxxxxxxxxxxx'
	option skip_inactivity_poll '1'
	option disassoc_low_ack '0'

With build r13023 some services like unbound "Save&apply" and "Save" options are greyed out (firefox, chrome, opera, etc).

r13023 piece_of_cake wifi http://www.dslreports.com/speedtest/62517009

Thanks.

Thank you Kong, r13044 fixed both issues.

Your problem of constant reboot is really fixed ?
At my side I'm still have the problem.. (version of today: KONG 20 r13044-3773ae127a). It looks that's clearly linked to wireless because as you said when I disable radio0/1 I don't have any more the problem but I also loose the wireless feature :laughing:

As workaround with the wifi feature, did you have the link of an old stable (trunk) version?
In the worst case I will use the standard with kernel 4.

Most likely not fixed, as there is an open issue with ath10k-ct https://github.com/greearb/ath10k-ct/issues/117 and non ct ath10k is bugged too, which after some time causes huge load on the cpu. Right now only 4.14 builds are stable. Of course you may not have a device e.g. older ipad that triggers the issue.

Thanks for your reply. I will switch to kernel 4.14 for now and keep an eye on the issue.

Nope, it only lasted 11 hours without rebooting.
Mistakenly deleted Kong's previous trunk versions with other stuff. Maybe someone else here...?

Cake is not as good as Kong's kernel 4. builds but still better than other K 5 builds.
This great improvement AQL and the ath10k is *lovely* makes it worth flashing K 5. and I've not experienced any rebooting with hnyman's kernel 5. versions.

2 Likes

Could you confirm me that the last build has DoH or DoT already installed ?

Thanks

I have the last Kong trunk build before all the rebooting started if you need it. Sysupgrade and image. I've since switched to hnymans.

By the way I see a similar error on the mt7621 builds, thus might be an issue with kernel 5.4.
Didn't experience this with the last build before mt7621 switched to 5.4.

I have an ea8500 running the trunk fw and a r7800 running the 19.07 fw, I just noticed adblock isn't working on either one. The r7800 is my production router, it would be nice to have adblock working on the r7800.
I tried to reload an old config backup but that didn't fix it. The only setting I've changed was to enable it and set the trigger to the WAN interface. Changing the trigger to unspecified didn't work.
The verson of the software is 4.0.4.
Anyone else seeing this as well?

Did you carry over a adblock config file from before adblock 4? If so, you need to reconfigure it from scratch, I think.

I've had it working on my R7800, but since the latest adblock 4 has been used I did need to restart from scratch as you can't use config files from 3.8 on 4.0+