Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...)

I've never actually used DD-Wrt so can't comment, I went from Voxels modified stock to openwrt, then back when I couldn't get it working with my mesh discs, but after lots of helpful advice I give it another go and it's now working, just hates a reboot with the mesh discs connected.

But I did read many many posts about Kongs work over at DD-Wrt and he was always highly regarded, so when I saw he was coming over to work on Openwrt I thought it would be a good thing, and ive used his firmware a few times and it's always been good, but I've found myself using a Hnyman build more often, mainly because he's active on the forum, helps when there's issues, tells you of the changes, provides manifests of what's included etc... Where as Kongs gets put on the desipro site and we hear nothing more... Someone did start a topic on here about his firmware and was updating it occasionally but It ended up being a slightly heated topic and got closed.

It's a shame as I'm sure his skill would be a benefit to the community in building better firmware if only he had the time/wanted to join in a bit more.

1 Like

I am wondering about moving to stock or another build too... I like Kong's work, but the build is also missing some packages I would like to try.

I have the recent Kong build for k 4, dtd 5/8/20, on a r7800 and k 5, dtd 4/29/20, on an ea8500. The k 5 on the ea8500 is working fine no reboots. However both routers have a problem with Adblock, seems to be broken, shows error in the status section of the Services-Adblock page. Version of Adblock is 4.0.4.
I think Kong builds his kernal with the services included. Can't install or update pre-installed services.
The only change I made to settings was to change target to WAN. This was in version 3 as well. I tried changing the setting back to unspecified, still had the problem. I changed the setting back to WAN, still had the problem.
Any guidance would be welcome.

Just installed Kong's k 5 (5-24-20 Trunk) on my r7800. Adblock is working. Adblock ver. 4.0.5.

Disabling ksmbd fixed the reboot issue with trunk builds, it only happens when connecting an old iMac via WiFi, all other devices are fine.

Kong's cake performance with both stable and trunk builds (r13910) are identical.

Thank you! Great work, as always.

Out of curiosity i checked the trunk build manifest and seems he installs both samba4 and ksmbd, so you have to make sure only one is actually running via startup. Whats also strange is that he only installs ksmbd luci and not samba4 luci, so you cant config samba4 via luci.

You can actually install both luci packages, you just get a duplicated named "network shares" entry, but you can figure out which is which by checking the settings/version names.

New build out

In Latest build minidlna is broken

From my experience, it also has been broken at the two latest R7500v2 firmwares (including the one from today). I tried different ideas from this forum to fix miniDLNA, but no luck. So, the only option was to install the 2020-07-09 build again.

Where to find previous builds?

I did try 5.4 and Kong trunk builds are still not optimized as much compare to 4.14.
Download speed is limited to 460 mbs only if SQM is selected even with ingress shaping disable and any discipline.

I keep a local copy of the best build for my R7500v2 to revert to it in case it's necessary. At the official Kong's site only the newest builds are available, AFAIK, and I don't know if there's a repository of previous builds somewhere.

Today's Kong Pro Firmware update for the R7500v2 fixed the miniDLNA issue of the previous two builds. Thanks, Kong, wherever you are!!

1 Like

Upgraded to the latest build here (dated 18/08) and performance is superb! I use a R7800 as the ISP facing router with two R6800 daisy chained as Wireless Access Points for the other floors of the house. Speed and stability seem much improved.

This one is KONG 19, 2020-07
ath10k is firmware ver 10.4b-ct-9984-fH-13-795874169 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,htt-mgt-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 123549a3

1 Like

I have a similar setup (R7800 as main router and 2 R7800's as APs). I can confirm that performance is great on Kong's 08/18/2020 build.

There is also another Kong build here (dated 23/07).

This one is KONG 20, r13910-0a5d74fa68.
ath10k is firmware ver 10.4b-ct-9984-tH-013-d81f62d97 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,htt-mgt-CT,set-special-CT,no-bmiss-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 7d7b454d

Although dated before KONG 19 it appears the latest so I will stick with it.

Note this firmware has no-bmiss-CT firmware option which Kong 19 does not.
no-bmiss-CT = ATH10K_FW_FEATURE_NO_BMISS_CT which is documented as follows:
/* SW Beacon Miss is disabled in this kernel, so you have to
* let mac80211 manage the connection.

Anyone know what this means practically?

There also seems to be a new build here
Based on reading some other threads, its sounds like the intent with this build is likely to add some performance improvements to offload processing.

That being said, when I load this build onto my R7800, it seems to screw up my networking. Namely, nothing that is hard-wired seems to be able to communicate with any of the wireless clients, and there also seems to be an issue with 2.4GHz clients not being able to communicate with 5GHz clients.

I read over another thread and tried a few iptables rules as well as some "hairpin_mode" settings alterations, but none of that seemed to fix it. The current trunk build here 07-23-2020, however, seems to be working just fine so I'm using that for now anyways.

Has anyone else tried the NSS build?

I'm trying out the Kong NSS build on 3 APs that run main wifi different SSID on both channels. I also have guest wifi running on both channels that are VLAN'd and isolated and kept the firewall running with 3 rules enabled to prevent LuCI and SSH access for connected guest wifi clients. I noticed on this NSS build having the firewall enabled broke my ability to obtain DHCP and DNS for the guest wifi networks from my main router. Disabled the firewall and everything worked again. Not sure what changed in this NSS build but something related to the firewall or related network rules. Everything was working as expected on the Kong 8/18 build with the firewall rules enabled. Haven't had time to troubleshoot anymore but the NSS build has been running fine for me for a few days.

Port forwards are not working on NSS build and something is not clean with SQM. Better to stay out for now from trunk builds

Yeah, I saw some discussion here on a different, yet related post that the firewall rules were not working as expected on NSS builds in general. These package installations seem to be what was identified as a fix, with the possible addition of some firewall rules as well.

That all being said - I tried the stop-gap solution of altering my firewall rules (moved LAN zone forward rule to 'accept' instead of 'reject') and that did work to enable my 5GHz, 2.4GHz, and wired clients to communicate on the NSS build. The problem was that the router went into a weird state about 10 hours later, where all of the wireless clients got kicked off until I rebooted the router. Seems that Kong's NSS build is pretty unstable.

I seem to be doing fine with the non-NSS trunk build (including port forwards), so I'm sticking with that for now.