Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...)

I cannot get Ksmbd to work on latest 23.05 NSS build with windows 11,it works fine on 22.03 on my XR500
any thoughts?

Having a problem getting NSS to start on the Kong 23.05 NSS build.
I'm using the R7800 on 1GB fiber.

SQM is enabled with the fq_codel discipline and the nss-rk-qos script on eth0.2.

I see on reboot that the qca-nss-mirred is disabled in the Startup Initscripts.
When attempting to enable it I get the message: Failed to execute "/etc/init.d/qca-nss-mirred enable" action: Command failed
I checked and the 1.1 kB file qca-nss-mirred does exist in the /etc/init.d directory.

I installed the Kong 23.05 build over the Kong 22.03 build and restored from a backup of the Kong 22.03 build. Mistake on my part?

Thanks

1 Like

@Slojoe I don't use Ksmbd sorry :frowning:

@KONG Everything has been great for me on my R7800. I am seeing the same pbr error that I mentioned in this post. Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...) - #491 by oreo

Also, I noticed a kernel error that I believe has to do with the network dropping Socket Kernel Buffers? Let me know what you think. But like I said everything has been great.

[89521.485016] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[89733.530394] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[92778.762025] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[92970.522267] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.202499] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.202952] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.210393] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.217017] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.224511] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.231822] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.239420] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.246482] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[114892.253529] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[118963.996434] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[128689.297641] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[130544.869473] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158090.676053] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158090.732962] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158090.733403] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.579780] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.580669] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.586431] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.594282] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.601537] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.608594] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.616328] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.623396] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.630833] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.638102] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.645558] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[158494.652929] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[164297.784199] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[164955.530580] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[164955.866334] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[164979.518912] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[165379.614573] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[165379.668378] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[168983.649285] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[168983.649531] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[174228.386537] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[175435.733410] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178183.627801] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178183.628133] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178535.631462] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178535.631901] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178535.943670] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178535.944149] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178535.969777] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.595964] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.596420] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.603714] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.610494] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.618027] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
[178547.625444] ipq8064-mdio 37000000.mdio eth0: nss_gmac_xmit_frames: dropping skb
1 Like

Make sure you don't enable software offloading under firewall tab, this would interfere with nss. I should probably remove that option in nss builds.

It's not enabled. I did a hard reset (pressing the reset button in the back of the router for 7-8 seconds) after flashing your 23.05 NSS build to start fresh. But I did double check it just in case right now and its definitely not enabled.

@KONG
It looks like its an issue with NSS builds on 23.05 and not specific to your 23.05 NSS build

Most likely a certain setting causes it, since I do not see this error on my setup.
It is only an informal message that is printed if the size of the package is below size of eth_hlen.

1 Like

@KONG any chance to add usb tethering packages to your builds?

Actually it should be included via packages, do you need any specific module?

Trying to get USB Tethering working with an iPhone and following the steps on Smartphone USB tethering.

Getting the following error on 23.05 nss build kong-ipq806x-generic-netgear_r7800-squashfs-sysupgrade.bin, released 2023-06-30 18:12:

root@OpenWrt:~# opkg install kmod-usb-net-ipheth usbmuxd libimobiledevice usbutils
Package kmod-usb-net-ipheth (5.15.117-1) installed in root is up to date.
Unknown package 'usbmuxd'.
Unknown package 'libimobiledevice'.
Installing usbutils (014-1) to root...
Downloading https://www.desipro.de/openwrt/repo/nss23/targets/ipq806x/generic/packages/usbutils_014-1_arm_cortex-a15_neon-vfpv4.ipk
Collected errors:
 * opkg_install_cmd: Cannot install package usbmuxd.
 * opkg_install_cmd: Cannot install package libimobiledevice.
 * check_data_file_clashes: Package usbutils wants to install file /usr/bin/lsusb
        But that file is already provided by package  * busybox
 * opkg_install_cmd: Cannot install package usbutils.

I see on router logs that it detects the USB connection, but USB interface doesn't appear.

There is also no notification popup on iPhone to trust device.

1 Like

Added the packages, try again.

Thanks! It worked.

For some reason, there was no usb* interface, it was under eth2 instead.

In the latest 23.05 nss build, I have the following issues:

  1. There is no "Custom Rules" section in the firewall page.
  2. Running vi gives the error "failed to source defaults.vim"

Btw, a special thanks for adding kmod-usb-net-dm9601-ether to the repository.

Builds >=22.x use now fw4 by default and have no custom rules section anymore. On my normal 22.x build I customized the firewall page however, where it is possible to add nft rules in custom rules section.

I have seen the vi error, have not investigated this yet.

1 Like

@KONG, thanks for the fw4 info. For now I have added the custom rules to Startup->Local Startup page.

Can't seem to get the 5 ghz channel to work on 160 Mhz setting on the new 23.05 NSS build. It just says that "Device is not active" Im on channel 100.

@KONG For some reason, WAN port is limited to 100mbps randomly. Updated to latest build but same issue.

Was using kong-ipq806x-generic-netgear_r7800-squashfs-sysupgrade.bin, released 2023-06-30 18:12, but updated to latest openwrt/23.05/ipq806x-nss release on 2023-08-06 21:22.

Check the cabling and the physical appearance of the ethernet ports on both devices first, it happens quite often that issues like these are getting resolved by replacing the ethernet cable due to slight defects.

1 Like

Yup, it appears to be an issue with the cable. Thanks @slh!

Was losing my mind since it would work at 1gb for some time before switching to 100.

Didn't expect the cable to fail since I've been using it without any changes for years.

I'm trying to switch to a different build but when I flash the sysupgrade through LuCI the procedure starts but in the end what ends up happening is that the router just reboots itself with no change to firmware whatsoever. What's going on? Do I have to use tftp?