Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...)

Is it possible to load and run crowdsec with this build? Could it be dropped into the repo?

-Pat

@Kong, I loaded the latest release 22.03 r19544 on my R7800. ddns-noip is not running and gives the following error when I try to start it:

011523 CRIT : Error in 'get_registered_ip()' - no supported Name Server lookup software accessible - TERMINATE

It was working okay in earlier releases (21.02 branch).

Btw, the repo no longer includes htop package.If you are adding packages, can you please add htop, usb-modeswitch, iftop, tcptrack,
Thanks

The DDNS error mentioned in the preceding post persists in version with release date 2022-08-27. I have reverted to the 21.02 version and there are no such problems there.

I got this error multiple times in multiple kong versions.....I think I solved it every time by installing bind-host package.

Regarding new kong builds, does anybody know if current kong build has pppoe gigabit speed fixed? I stopped upgrading kong builds some months ago because with my pppoe connection I had poor internet speed....Thank you

Curious about this as well.

You need to use ACwifidude NSS images. They have the PPPoE patch recently pushed by Tishipp. A few people have confirmed that NSS offloading works for PPPoE in 22.03 and master images now.

1 Like

Using logon84 suggestion, I installed bind-host and the ddns problem is gone.

Thanks.

@KONG could you please include Adguard's dnsproxy in your repo?
Got better results with dnsproxy (option cache_optimistic '1') than included https-dns-proxy

Thank you
Edit: nss build r19841, 160MHz setting channel 100 results in104 being used instead (clean install).

@KONG does your NSS build support 802.11v and k? I tried using the UCI set command on the shell and returned an error. As far as I can see 802.11r is enabled and working/not causing issues, nut perhaps not working optimally without v & k?

Yes, this v and k should be supported.
Are you following this guide:

1 Like

It's possible I was using something different - will double check and try again when I get home! Thank you for the reply :blush:

What do you mean by better results? I'm running http-dns-proxy + dnsmasq for 100+ clients of course you have to choose the right servers, some of them in the list are no good. You can easily tell by dumping dnsmasq stats. Also you should increase dnsmasq cache if you have quite some dns traffic.

1 Like

Thanks Kong. All good using those instructions and the Dawn installed via UI from your repo.

@KONG I cannot connect to the R7800 in failsafe mode.

OpenWrt (KONG 22 r19544-5095bdcc6f) no longer accepts my credentials for some weird reason (unless NSA has visited me as everything else works), and i have not changed them. I tried to reset the password in failsafe mode, but it looks like failsafe is not working on your build? I have done the usual procedure described everywhere.

  1. enter failsafe by removing WAN connection, powering on the router and pressing reset button for 2s upon startup (when power LED is blinking fast)
  2. The power LED on R7800 flashes really fast in red color - indicating it is in failsafe mode
  3. My USB ethernet adapter is configured with static IP:

IPv4 Address. . . . . . . . . . . : 192.168.1.2
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1

  1. Cannot connect to the router, either via SSH (22) or Telnet (23) using putty, when connecting to 192.168.1.1 and USB adapter is connected to any of the 4 ethernet ports or WAN port (tried all, as guides are inconclusive which to try).

Any help here please? Is SSH (telnet could have been removed) using different port in your build?

Reset Button for 2s after pressing power on does nothing. This is still the time when uboot loads.
Either Power on and wait for around 20s until unit is done booting, then press reset button which which reset the device.
Or press reset button and hold it for around 15s until the power led flashes white, then it is tftp mode, which allows you to upload a new firmware through tftp, which will also clear anything on the next boot.

I would like to reset password only via failsafe mode, not to reset it. So is the process above going to wipe the device (I would love to keep entire router configuration) or just enter failsafe correctly? The 'vanilla' OpenWrt guides describes entering failsafe similar way to what I have done.

There's nothing wrong with the ROM, it's rather amazing. Thank you for your work on DD-WRT and now on OpenWrt. Personally, I was always on your ROM as I value expertise brought from the other platforms. My LAN/WLAN is fully working as configured (WPA3/guest/IOT etc.) - I just cannot enter the router. I know I can wipe the device easily, then just flash new ROM via WebUI. I but don't want to do that as I don't have my config backed up.

Thank you again. And last thing - always on NSS build so sometimes reporting bugs (the most common was 5G stopping working but is rock solid for 2 weeks now strangely, hence NSA must have done something to my router ;-))

Yes, the methods I mentioned will wipe your config. Failsafe may work, but it is probably tricky to get the right moment as the unit boots pretty fast. Have you checked the the tcpdump method, to see if you receive a package with "Please press button now to enter failsafe".

1 Like

Please make a 22.03-NSS build with no extra packages included.

I have just installed Kong build 22.03 release 19882-3564c22e46. Is it possible to add the following packages to it:

  1. kmod-usb-net-dm9601-ether
  2. python3-pip
  3. temperusb
  4. iftop

They were in the 21.02 build. I would really appreciate it if you can add these to the 22.03 builds as well.

Is it possible for me to compile these packages myself? Can you please point me in the right direction?

Thanks,
Khurram

I have just installed Kong build 22.03 release 19882-3564c22e46. Is it possible to add the following packages to it:

1. kmod-usb-net-dm9601-ether
2. python3-pip
3. temperusb
4. iftop

I downloaded files 2-4 from OpenWRT 22.03.3 downloads.

The downloaded file for kmod-usb-net-dm9601-ether from OpenWRT 22.03.3 kmods does not install as it is built for a higher kernel version than Kong's; the one from OpenWRT 22.03.2 kmods didn't work either as its kernel version is less than Kong's. Can you please build and add kmod-usb-net-dm9601-ether to the repository?

Thanks
Khurram