Kong pro firmware for IPQ806x (R7500, R7800, EA8500, ...)

I posted because I assume he reads threads here, regardless of not responding. Unless devs are super alienated they love seeing responses to their work. So probably reading, just not responding, at least I hope. Otherwise there isn't any other way to notify him on his builds and issues with them.

anyone know the latest version of 19.7 that Kong's builds are using? later than 19.7.1?


I'd like to know if some tried /use the last Kong build on R7800?
I want to try open wrt and I've read many good thing about kong.


I've used all kong builds... Even the trunk 5.4 kernel ones on my R7800... They are very optimized for speed, however they are also a very feature rich build, I found it had a load of add-ons that I never bothered setting up as I didn't want/need them.... So still revert to hnymans builds as it's 1/3 of the size and has everything I need from my router apart from the tcpdump package that I install afterwards.


Latest build is working great. I'm on 15 day uptime. No issues.

And the latest is the one I see : March 3?

Latest is 3rd April I believe....


1 Like

I didn't even see the trunk build. I'm using the March 22 one.


And maybe a newbie question but what is the difference with the trunk version?

I THINK trunk has the newer 5.x kernel but not 100% sure haven't been following dev that closely. Anyone please correct if I'm wrong.

1 Like

Trunk version is his version of the master snapshop builds, so it's kernel 5.4 and a few later tweaks.

His other build is based on the latest stable release... And kernel 4.19

1 Like

Does anybody have any experience with wds and vap using kong openwrt? It seems that ddwrt latest build for the netgear r7800 have wds and vap as known problems.

1 Like

can I upgrade from kong build (march 22 - 4.19kernel) to trunk version?? from LuCi?


Yes I've done so...

1 Like

And pretty stable?
And no problem to keep setting?

I notice adblock is broken on an upgrade to Kongs latest 17/04 upload. Error shown below on the overview tab. I'm not clever enough to work out what is wrong - hopefully a simple fix - anyone any clues, seen it and fixed it themselves?

Expected ';'
  at Anonymous function (
  at Anonymous function (
  at m (

Update your luci-* and rpcd-packages via opkg package manager.

Thanks for the reply.

Sadly, I think that is beyond me so I'll go back to the previous build and try the next one when it is up. If I go to system>software and 'update lists', the updates list is empty - I presume it points to Kongs repository. If I break something and I lose the internet my family will hound me! :laughing:

I'm in a similar boat as the last few Kong trunk builds send my router into an endless boot loop right after sysupgrade. I can't dedicate time to figuring it out so I tried hnymans latest build and it's working great while maintaining the same configuration + adding Kong's startup script. Can't afford any down time with everyone home right now with this pandemic.

If anybody wants to try hnymans build for R7800, see here:

1 Like