Koalasafe K150N

Hi everyone,

I'm trying to install open-wrt to a Koalasafe K150N.
Koalasafe were a company who made a Family friendly router, but they closed down in Feburary 2021.
At the time, they pushed out a build of Open-wrt to their routers if they were switched on.

" Hardware Conversion

Before the end of February we will try and push OpenWRT to all KoalaSafes that are still online. This will convert them to standard routers. If the conversion is successful, you'll see the WiFi name change to something starting with GL."

Now, my router wasn't on at the time, so I didn't get the build.
I've actually been playing around with the Koalasafe (which from their message, seems to be based on a Gl.inet router - and indeed looks identical to a Gl-inet Ar150 and trying to work out which firmware's might work, which build they released!

So, for starters, you can reset one and gain access (at least for the model I have, which is an KS-150N), by following Gl-inets' instructions here;


I followed the instructions for the Gl-inet GL-AR150 (reasoning that the model numbering and the fact they look the same meant the Koalasafe was the same or similar hardware) and installed the Open-wrt firmware from here;


Which worked insofar as the Ks-150n router is now handing out an ip address to my pc.

What it's not doing is detecting the WAN connection from my modem...it shows the port as disconnected. Problem!

Now, the Ks-150N running Open-wrt show itself as having an AR9330 in the system logs.

Whereas the Gl-AR150 is listed as having an AR9331.https://openwrt.org/toh/gl.inet/gl-ar150

So I think I'm close...but I'm going to try some firmwares for devices with an AR9330 like these and see if I get anywhere;

Let me know if anyone else gets it working, would love to know which firmware works properly on the Koalasafe Ks150n or how to address this!

Hello, have you had any success with your efforts? I completely missed the KoalaSafe shutdown just as well and finely had a little time to start browsing on what to do. I think I've only come across your post in regards to the K150N.

I have. Managed to get a different firmware onto the box and it works ok. Bit slow but solid.
Best advice is to try different firmwares for the GL-AR150

1 Like

Thanks. I will try that.

The GL bootloader has web recovery, so forcing in a new firmware to replace faulty or unknown firmware is not complicated.


Luckily for me, it never bricked. It was more just finding the right firmware that actually worked without not detecting the ethernet port.
This one worked;


Use the latest.