Kmod-sctp missing dependency under kernel 5.15

I tried to build master today (target rockchip, using Kernel 5.15) and ran into an interesting issue I never faced before. The building fails with:

Package kmod-sctp is missing dependencies for the following libraries:

It seems I need to remove LINUX_5_15: from line 1161 (, then everything works.

Does anyone know why I need to explicitly remove LINUX_5_15:, I can't figure it out.

Can you test the same with 5.10?

I ran some further tests and did not face the issue. In each case (5.10, 5.15, 5.15 including pr10123) I sticked to building plain OpenWrt (without the packages feed) and only added kmod-sctp compared to the defaults.

I'll now try to perform some further tests with the packages feed ... hopefully I manage to narrow it down even further.

I think I found the problem ... 100% my fault. It seems one should update and install the packages feeds after modifying the kernel config. When first modifying the kernel config and then updating and installing the packages feeds I faced the issue ... in reverse order not. Very strange. Anyway, now everything works.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.