Kmod-mwlwifi_5.15.127 arm_cortex-a9 for testing

Hi Wild,


First, install with no options, reboot to see if it's stable.
In second time, add the options.





Did you mean to tag someone?

@WildByDesign ?

Are you asking for people to test your package?


|Model|Linksys WRT1900ACS|
|Architecture|ARMv7 Processor rev 1 (v7l)|
|Target Platform|mvebu/cortexa9|
|Firmware Version|OpenWrt 23.05.0-rc3 r23389-5deed175a5 / LuCI openwrt-23.05 branch git-23.236.53405-fc638c8|
|Kernel Version|5.15.127|

wrt1900acs v2 works without problems for 20 minutes,unfortunately, only wifi on the PC knows wpa3 !

@jbsky if you need some information, contact me privately!

mwlwifi options: feature=0x30 ON!!!

Alright, I will jump into this later tonight with my WRT3200 and test exactly as you mentioned. I will test later in the evening and have some details for you by tomorrow morning.

1 Like

@oli That’s great news that you have been having success with WPA3. Most people here never expected WPA3 to ever work on mwlwifi after the big companies abandoned it.


Thanks to @ Jbsky



When you update the module, the 50-mwlwifi file is overwritten, so you have to re-enter the feature.

The PC still maintains a connection even if the feature is set to 0.
I haven't observed this behavior with the phone.

1 Like

I have some good news. This most recent test driver works great on WRT3200 by default.

The bad news is that the mwlwifi options: feature=0x30 setting is specifically what is causing the boot loop. So for whatever the reason, WRT3200/32X does not like that option and puts the OpenWrt OS into a continuous boot loop.

I hope this information is helpful in digging into a more specific area of code. I believe that it may narrow things down a bit.


try first

mwlwifi options: feature=0x20

Here you can test whether WPA3 works.

Then try feature=0x30.

thank you


I woke up extra early this morning so I figured I would jump right into this testing at the start of the day today.

I have some good result for you:

mwlwifi options: feature=0x20   Success
mwlwifi options: feature=0x30   Success

When I say Success, I am simply referring to the fact that the OpenWrt OS boots up and the driver loads successfully. So no boot loop at all.

The driver loads with no options (default), with mwlwifi options: feature=0x20 and with mwlwifi options: feature=0x30 all successfully.

Speed tests are all good. General wifi functionality is all as per normal.

But I have not tested a config with WPA3 yet. I will do that later in the day.

I am very excited with this progress. Excellent job, Julien.

1 Like

I implemented the new ones, everything works correctly on wrt1900acs v2

1 Like

My TV sees the wifi network with wpa3 but strangely it cannot connect, the phone supports 5Ghz but does not support this security standard but it does not see the wifi network either, how do devices that do not support this standard behave?

In addition to plain WPA3, the failing point has been a crash/lockup some time after both WPA2 clients and WPA3 clients are connected, to

  • a single mixed WPA2/WPA3 SSID (with 802.11w set as "optional" = 1) or
  • into separate WPA2 (802.11w=0) and WPA3 SSIDs (802.11w=2).
1 Like


I'm having trouble understanding, have you tried the driver I provided and it crashes with mixed mode WP2/WPA3?

I have not tried it. I have no access to my WRT3200ACM right now.

My comment was just meant as testing advice, that with the earlier/original unpatched driver, WPA3 may seem to work for some time with just a single WPA3 enabled device being connected, but the driver may crash later when there are multiple devices connected with varying WPA2 & WPA3 capabilities. So, purely testing WPA3 may not be quite enough.

(I used WRT3200ACM to some extent in 2017-2021, but have largely abandoned it since then.)

1 Like

@jbsky What is the difference between mwlwifi options: feature=0x20 and mwlwifi options: feature=0x30?


#define HW_SET_PARMS_FEATURES_HOST_BEACON             0x00000010
#define HW_SET_PARMS_FEATURES_HOST_PROBE_RESP         0x00000020

This allows you to deactivate a function programmed into the chip that replaces the beacon or prob response.

1 Like

Thank you, that was good information.

I had no issues with default mwlwifi options. However, I did end up having drastic performance issues (WRT3200) with the mwlwifi options: feature=0x30 setting.

It had seemed good initially, but after a small amount of time it started to take 30-60 seconds for any web pages to load, including the local network for the router webui. Some web sites even showed up as a blank white page, empty.

So while the driver loads now without causing a boot loop, the 0x30 option ended up being very problematic.

I ended up removing the option and using the same driver, everything is running great.

try only 0x20 please

Ok, I will run a test later in the day with that option and keep that overnight to see how it performs. I will let you know by tomorrow morning.