Kindle Won't Connect

Hi Everyone,

I'm having issues connecting an older kindle (2.4GHz only) to my network. I have tested the kindle for WiFi issues, but it connects fine to my phone hotspot and also fine to the bundled TalkTalk router at my mum's (combined 2.4 and 5GHz bands), so it doesn't seem to be an issue with the Kindle itself.

My setup at home consists of two Linksys MR8300 routers that are hard linked with the WiFi channels using 802.11r fast switching via OpenWRT 19.07. This has worked fine for all devices I have tried to connect, apart from the Kindle. I initially thought it might have been the fast switching feature that was not compatible, but I setup a test 2.4GHz SSID with no security and no fast switching, but the device still failed to connect.

Any ideas anyone?



The Wifi channel you use?
The encryption you use?

Just to add to what @faser mentioned, I’ve had problems with older devices when management frame protection is enabled, even when set to optional, so you might try disabling it too if you have it enabled.

1 Like

Thanks for the reply! I have tried it on both 1 and 11. The test SSID I setup was without encryption.

Thanks for the tip - I'm away at the moment, but I'll check this when I get home!

Ok, I'm back home now and I can confirm that MFP was already disabled. I've also done some more messing about and my current config is as follows:

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option cell_density '0'
        option country 'GB'
        option channel '11'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'lan'
        option disassoc_low_ack '0'
        option short_preamble '0'
        option wmm '0'

Please note the above is for test only, and I am aware there is no encryption enabled! :slight_smile:



Ok, figured it! It appears to be due to PiHole blocking something, which is odd as a latest gen kindle connects fine (albeit to the 5GHz band) with PiHole still enabled. Very strange.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.