[Kinda Solved] Luci-app-statistics: graphs recently broke

Sometime over the past month or two, luci app statistics graphs broke for me.

Currently I'm running OpenWrt SNAPSHOT r12416-b9c1cf1657 (r7500v2) built with imagebuilder.
I have:

luci-app-statistics - git-20.061.71931-cf09705-1

The symptom(s) are graphs do not appear as usual. Instead I see broken links. The last known working version of luci-app-statistics for me was January time frame.

I've tried updating /etc/config/luci_statistics

I don't see anything obvious from logread, but upon /etc/init.d/luci_statistics restart, I did see

Thu Mar  5 07:08:43 2020 daemon.err collectd[10961]: configfile: stat (/etc/collectd/conf.d) failed: No such file or directory

and this directory and file are missing.

Any hints?


graphs appear on chrome but not firefox...

I'll play with deleting firefox history.

EDIT: deleting firefox history brought the graphs back.

Now I have to log back into everything...

And subsequently, I made a change to the cpu graph settings which broke the graph until I cleared history again.

Is this the expected behavior?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.