Kimax BS-U35-WF cannot install samba4

Hi, I want to use SMB protocol to connect to my nas from my phone
How can solve this small memory issue to install samba4?

After running opkg install luci-app-samba4 I get this error

See this:

1 Like

Samba is huge, replace it with ksmbd.

1 Like

@psherman Thanks I looked into and I might try it as a last resort.
@frollic I thought something is missing in ksmbd and I couldn't get it to work .Thats why I tried to install samba.
Could you give me some tips on how to use it ? I just enter the IP address, username and password on my phone but I get nothing.
edit: typos

Sounds like there's something wrong the shares, if you get nothing.

I'll try tomorrow, it's too late for me, need my beauty sleep, and I've got a Cujo device to disassemble.

1 Like

where do I tell it to share a certain folder or hard drive ?

I took a hint from @Annick
This my setup now I still cant connect on my phone

This how I try to connect what am I doing wrong ?

samba problem login / password solved

Enable insecure guest logon

I want to login with a password not as guest. Plus I'm using an Android phone.

Your first picture is with guest !!!

Look :

That was to show I tried with guest and it does not work.
This Sambashare from the guide where is it in ksmbd ?
I tried everything I know still cannot connect :frowning:

You use what ?

I not use with smartphone

Test quickly with PlayStore -> ESuperFichier & no problems

I use CX file explorer

The device was connect to my home router via wifi. Now I connected it via LAN. This is what I get on windows it asks for login
the password is the same password I use to login to the kimax right ? why is it incorrect.
It still does not connect on my phone too.

config samba
        option workgroup 'WORKGROUP'
        option charset 'UTF-8'
        option description 'Samba on OpenWRT'

config sambashare
        option name 'USB'
        option path '/mnt'
        option read_only 'no'
        option guest_ok 'yes'
        option create_mask '0666'
        option dir_mask '0777'

For login WIndows 11 look:

1 Like

Thanks bro your comments helped me a lot but it still did not work for me . I ended up using SFTP

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.