Kernel Warning: "Received packet with own address as source address" whenever adding the device 'br-wan'

Hi,

I'm using the 8devices Lima-I module and have the following problem.

I want to create a device named 'br-wan' by configuring the /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf6:726f:cf4a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'eth1'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

After restarting the network, the terminal continuously appears warnings as below.

[ 1146.493552] br-wan: received packet on eth1 with own address as source address (addr:c4:93:00:3b:9f:fb, vlan:0)
[ 1149.508383] br-wan: received packet on eth1 with own address as source address (addr:c4:93:00:3b:9f:fb, vlan:0)
[ 1152.523537] br-wan: received packet on eth1 with own address as source address (addr:c4:93:00:3b:9f:fb, vlan:0)

When I removed the 'br-wan' device and assigned the 'wan' interface directly to the 'eth1' port like the /etc/config/network file below, the warnings disappeared!

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf6:726f:cf4a::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'

Could you please explain to me where I misconfigured it?

Thanks.

Is there anything else configured against the bridge (such as a STA mode wifi connection)?

Generally, there is no reason to use a bridge on the wan. I'm not exactly sure I could explain why that error appears, but the direct assignment of the port is usually preferred.

The only reason I would see to use a bridge on the wan would be if you needed to do a "pass-thorugh" using additional ports on your device so that you'd basicaly have a 2-ports (or more) assigned to the wan from a signaling standpoint with a connection to the wan network interface within OpenWrt. This would not be useful in most normal situations, but could be handy when you have multiple IP addresses available via the upstream (simple example: the router in question is behind another NAT router).

2 Likes

Sorry for the late reply.

Is there anything else configured against the bridge (such as a STA mode wifi connection)?

This is my /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '0'
        option txpower '14'
        option legacy_rates '0'

config wifi-iface 'wifi0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'wireless-hotspot'
        option key 'rfics#345'
        option encryption 'psk2+ccmp'
        option wds '1'
        option ieee80211r '1'

And I don't think it conflicts with the bridge setting.

I want to use a bridge on the wan interface because I want to assign multiple static IP addresses on it, for example below.

config device
        option name 'br-wan'
        option type 'bridge'
        option ports 'eth1'

config interface 'wan'
        option device 'br-wan'
        option proto 'dhcp'

config interface 'wan2'
        option device 'br-wan'
        option proto 'static'
        option ipaddr '10.223.159.252'
        option netmask '255.255.0.0'

config interface 'wan3'
        option device 'br-wan'
        option proto 'static'
        option ipaddr '192.168.0.102'
        option netmask '255.255.255.0'

If I don't use a bridge, is there another way I can achieve my goal?

Ty.

Are the mac addresses of br-lan and br-wan the same? The command ip addr will tell you.

1 Like

Have you tried just doing that without the bridge? Just create multiple "logical" interfaces on device eth1 and assign different static IP addresses... I think I did something like that in the past and it sort of worked...

1 Like

Thank you but the output of ip addr shows that br-lan and br-wan have different addresses.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether c4:93:00:3b:9f:fa brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-wan state UP qlen 1000
    link/ether c4:93:00:3b:9f:fb brd ff:ff:ff:ff:ff:ff
4: teql0: <NOARP> mtu 1500 qdisc noop state DOWN qlen 100
    link/void
11: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether c4:93:00:3b:9f:fa brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fdf3:8c81:983c::1/60 scope global noprefixroute
       valid_lft forever preferred_lft forever
    inet6 fe80::c693:ff:fe3b:9ffa/64 scope link
       valid_lft forever preferred_lft forever
12: br-wan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether c4:93:00:3b:9f:fb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::c693:ff:fe3b:9ffb/64 scope link
       valid_lft forever preferred_lft forever
13: phy0-ap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether c4:93:00:3b:9f:fc brd ff:ff:ff:ff:ff:ff
    inet6 fe80::c693:ff:fe3b:9ffc/64 scope link
       valid_lft forever preferred_lft forever

Ty, I'll try it and let you know when I get the results.

1 Like

Sorry for the late reply, I was busy with some other work before coming back to this topic.
And as you said, I just need to create multiple interfaces on device eth1. Thank you.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.