Kernel warn - TP-link C6U - Mesh network not possible - general networking becomes unusable

Anyone has an idea or seen this happening too ? Mesh on these units seems not usable

Platform:

kernel : Linux caretaker1 5.4.154 #0 SMP Sun Oct 24 09:01:35 2021 mips GNU/Linux
openwrt release: openwrt-21.02.1-ramips-mt7621-tplink_archer-c6u-v1-squashfs-factory
hardware: tplink,archer-c6u-v1 ( x 2 ) - Tp-link Archer C6U
wifi drivers MediaTek MT7613BE 802.11nac and MediaTek MT7603E 802.11bgn

How to reproduce:

Create a mesh network on the 2.4GHz radio0 (5GHz will not associate at all) , reboot both routers. They will fail to associate and both will report this error with about a second difference during attempt to form mesh, this exact error happens on both units. It happens when using encryption, but also when not using encryption. Nodes will fail to join the mesh.

additional symptoms:

The ethernet bridge will stop functioning too, so even when cable connects both routers, after this, pinging eachothers bridge lan ip will not work, reboot is needed. The softswitch seems impacted

using WDS this doesn't seem to happen, only using mesh.

source code line: https://elixir.bootlin.com/linux/v5.4.154/source/net/core/flow_dissector.c#L960

while testing at first it looked like an encryption issue (SAE auth failure), so tried to use wolf-ssl and openssl, eventually turning off encryption but this problem still pops up.

You actually don't even need a second router, it can be triggered with a single node, just prepare config and enable the disabled radio for it to happen, but when using 2 routers, the error usually shows in both at about the same second when activating both radio's simultaniously.

warn stack:

[   23.129204] WARNING: CPU: 3 PID: 825 at net/core/flow_dissector.c:960 0x8042bd24
[   23.136649] Modules linked in: pppoe ppp_async iptable_nat xt_state xt_nat xt_conntrack xt_REDIRECT xt_MASQUERADE xt_FLOWOFFLOAD xt_CT pppox ppp_generic nf_nat nf_flow_table_hw nf_flow_table nf_conntrack mt7615e mt7615_common mt7603e mt76_connac_lib mt76 mac80211 ipt_REJECT cfg80211 xt_time xt_tcpudp xt_multiport xt_mark xt_mac xt_limit xt_comment xt_TCPMSS xt_LOG slhc nf_reject_ipv4 nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_filter ip_tables hwmon crc_ccitt compat ledtrig_usbport nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 tun leds_gpio xhci_plat_hcd xhci_pci xhci_mtk xhci_hcd gpio_button_hotplug usbcore nls_base usb_common
[   23.199177] CPU: 3 PID: 825 Comm: kworker/u9:1 Not tainted 5.4.154 #0
[   23.205621] Workqueue: napi_workq 0x8043c9d8
[   23.209885] Stack : 00000000 80850000 805f82dc 86e3ba3c 00000000 00000000 00000000 00000000
[   23.218210]         00000000 00000000 00000000 00000000 00000000 00000001 86e3b9f0 5f98de5d
[   23.226534]         86e3ba88 00000000 00000000 00000000 00000038 805ebea4 616e203a 775f6970
[   23.234858]         00000000 00000001 00000000 00032335 00000000 86e3b9d0 00000000 8042bd24
[   23.243181]         00000009 86e851d4 861d8c18 00000000 00000003 8035cbf4 0000000c 8082000c
[   23.251505]         ...
[   23.253940] Call Trace:
[   23.253982] [<805ebea4>] 0x805ebea4
[   23.259889] [<8042bd24>] 0x8042bd24
[   23.263366] [<8035cbf4>] 0x8035cbf4
[   23.266846] [<8000b05c>] 0x8000b05c
[   23.270318] [<8000b064>] 0x8000b064
[   23.273787] [<805d17d8>] 0x805d17d8
[   23.277259] [<8007ab80>] 0x8007ab80
[   23.280732] [<8002c3d0>] 0x8002c3d0
[   23.284205] [<8042bd24>] 0x8042bd24
[   23.287678] [<8002c478>] 0x8002c478
[   23.291158] [<8042bd24>] 0x8042bd24
[   23.294633] [<8043af0c>] 0x8043af0c
[   23.298109] [<805a8b8c>] 0x805a8b8c
[   23.301592] [<805ad758>] 0x805ad758
[   23.305069] [<805aba7c>] 0x805aba7c
[   23.308553] [<805ad960>] 0x805ad960
[   23.312042] [<8642b958>] 0x8642b958 [mac80211@d2cffd49+0x7d550]
[   23.317937] [<80054a24>] 0x80054a24
[   23.321407] [<800521f4>] 0x800521f4
[   23.324892] [<8042d2ec>] 0x8042d2ec
[   23.328363] [<805ae02c>] 0x805ae02c
[   23.331860] [<86433104>] 0x86433104 [mac80211@d2cffd49+0x7d550]
[   23.337762] [<8642ff78>] 0x8642ff78 [mac80211@d2cffd49+0x7d550]
[   23.343683] [<8643935c>] 0x8643935c [mac80211@d2cffd49+0x7d550]
[   23.349616] [<8643b060>] 0x8643b060 [mac80211@d2cffd49+0x7d550]
[   23.355531] [<80030598>] 0x80030598
[   23.359009] [<805f22f4>] 0x805f22f4
[   23.362496] [<800308fc>] 0x800308fc
[   23.365969] [<8043c908>] 0x8043c908
[   23.369440] [<80030a00>] 0x80030a00
[   23.372913] [<8043c9fc>] 0x8043c9fc
[   23.376392] [<8043c9fc>] 0x8043c9fc
[   23.379865] [<8043ca24>] 0x8043ca24
[   23.383340] [<805ed2b0>] 0x805ed2b0
[   23.386815] [<805ed784>] 0x805ed784
[   23.390293] [<80045f34>] 0x80045f34
[   23.393767] [<800462f0>] 0x800462f0
[   23.397240] [<805ed428>] 0x805ed428
[   23.400719] [<80046188>] 0x80046188
[   23.404194] [<8004bbe4>] 0x8004bbe4
[   23.407666] [<8004baa4>] 0x8004baa4
[   23.411145] [<8004baa4>] 0x8004baa4
[   23.414619] [<8004baa4>] 0x8004baa4
[   23.418094] [<80006718>] 0x80006718
[   23.421587]
[   23.423373] ---[ end trace a7506b29926c91c1 ]---

loaded kernel modules

cfg80211              276544  5 mt7615_common,mt7603e,mt76_connac_lib,mt76,mac80211
compat                  1344  2 mac80211,cfg80211
crc_ccitt               1696  1 ppp_async
gpio_button_hotplug     7008  0
hwmon                   7392  1 mt7615_common
ip_tables              11488  4 iptable_nat,iptable_mangle,iptable_filter
ip6_tables             11264 24 ip6table_mangle,ip6table_filter
ip6t_REJECT             1248  2
ip6table_filter          928  1
ip6table_mangle         1344  1
ipt_REJECT              1184  2
iptable_filter           896  1
iptable_mangle          1056  1
iptable_nat             1088  1
leds_gpio               3008  0
ledtrig_usbport         2768  0
mac80211              513360  5 mt7615e,mt7615_common,mt7603e,mt76_connac_lib,mt76
mt76                   38624  4 mt7615e,mt7615_common,mt7603e,mt76_connac_lib
mt76_connac_lib        17408  2 mt7615e,mt7615_common
mt7603e                38304  0
mt7615_common          64320  1 mt7615e
mt7615e                11232  0
nf_conntrack           75536  8 xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_MASQUERADE,xt_CT,nf_nat,nf_flow_table
nf_defrag_ipv4          1216  1 nf_conntrack
nf_defrag_ipv6          5712  1 nf_conntrack
nf_flow_table          15408  2 xt_FLOWOFFLOAD,nf_flow_table_hw
nf_flow_table_hw        2416  1
nf_log_common           2976  2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4             3616  0
nf_log_ipv6             4320  0
nf_nat                 26000  4 iptable_nat,xt_nat,xt_REDIRECT,xt_MASQUERADE
nf_reject_ipv4          2272  1 ipt_REJECT
nf_reject_ipv6          2688  1 ip6t_REJECT
nls_base                5296  1 usbcore
ppp_async               7344  0
ppp_generic            24848  3 pppoe,ppp_async,pppox
pppoe                   9152  0
pppox                   1296  1 pppoe
slhc                    5280  1 ppp_generic
tun                    34400  0
usb_common              2704  3 xhci_plat_hcd,xhci_hcd,usbcore
usbcore               141312  5 ledtrig_usbport,xhci_plat_hcd,xhci_pci,xhci_mtk,xhci_hcd
x_tables               15696 24 xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_MASQUERADE,xt_FLOWOFFLOAD,xt_CT,ipt_REJECT,xt_time,xt_tcpudp,xt_multiport,xt_mark,xt_mac,xt_limit,xt_comment,xt_TCPMSS,xt_LOG,iptable_mangle,iptable_filter,ip_tables,ip6table_mangle,ip6table_filter,ip6_tables,ip6t_REJECT
xhci_hcd              115200  3 xhci_plat_hcd,xhci_pci,xhci_mtk
xhci_mtk                4928  0
xhci_pci                3680  0
xhci_plat_hcd           5856  0
xt_CT                   2912  0
xt_FLOWOFFLOAD          3248  0
xt_LOG                   768  0
xt_MASQUERADE            832  1
xt_REDIRECT              704  0
xt_TCPMSS               3168  4
xt_comment               512127
xt_conntrack            2432 14
xt_limit                1312 20
xt_mac                   640  0
xt_mark                  672  0
xt_multiport            1312  0
xt_nat                  2432  0
xt_state                 832  0
xt_tcpudp               1824 12
xt_time                 1952  0

config to reproduce:

network config:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdc7:d638:2fc8::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option ipv6 '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.0.1'
        list dns '192.168.1.2'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

wireless:


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option country 'BE'
        option cell_density '0'
        option htmode 'HT20'
        option channel '11'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'mesh'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option key '2Hot4u3hardy'
        option mesh_id 'wecare2'
        option encryption 'none'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option country 'BE'
        option cell_density '0'
        option channel '44'
        option noscan '1'
        option diversity '1'
        option log_level '1'
        option tx_stbc '1'
        option rx_stbc '2'
        option su_beamformer '1'
        option rts '512'
        option htmode 'VHT40'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option key '2Hot4u3hardy'
        option mode 'ap'
        option wds '1'
        option ssid '2care'
        option encryption 'psk2'
        option ieee80211r '1'
        option mobility_domain '3d34'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'

all installed packages (both devices are identical)

opkg install iwinfo
opkg install liblucihttp0
opkg install cgi-io
opkg install luci-lib-base
opkg install opkg
opkg install luci-app-opkg
opkg install ubus
opkg install iw
opkg install libuci20130104
opkg install rpcd
opkg install busybox
opkg install luci-lib-ip
opkg install libubus-lua
opkg install kmod-nf-reject6
opkg install libiwinfo-lua
opkg install luci-mod-system
opkg install kmod-nf-flow
opkg install libnl-tiny1
opkg install libustream-wolfssl20201210
opkg install kmod-lib-crc-ccitt
opkg install libwolfssl4.8.1.66253b90
opkg install getrandom
opkg install luci-theme-bootstrap
opkg install kmod-pppoe
opkg install kmod-pppox
opkg install kmod-ipt-conntrack
opkg install kmod-nf-reject
opkg install base-files
opkg install kmod-nf-nat
opkg install libubus20210630
opkg install libjson-script20210516
opkg install kmod-mt7615e
opkg install netifd
opkg install dnsmasq
opkg install procd
opkg install ubusd
opkg install px5g-wolfssl
opkg install luci-mod-status
opkg install libxtables12
opkg install kmod-usb3
opkg install firewall
opkg install luci-app-firewall
opkg install kmod-nf-ipt
opkg install wpad-openssl
opkg install ubi-utils
opkg install kmod-ip6tables
opkg install odhcp6c
opkg install fstools
opkg install uclient-fetch
opkg install uci
opkg install lua
opkg install luci-ssl
opkg install libip4tc2
opkg install dropbear
opkg install rpcd-mod-file
opkg install mtd
opkg install odhcpd-ipv6only
opkg install libblobmsg-json20210516
opkg install libiwinfo-data
opkg install rpcd-mod-luci
opkg install urandom-seed
opkg install luci-proto-ppp
opkg install luci-mod-dashboard
opkg install luci-mod-admin-full
opkg install ppp
opkg install luci-base
opkg install kmod-leds-gpio
opkg install kmod-gpio-button-hotplug
opkg install logd
opkg install kmod-mt7603
opkg install luci-proto-ipv6
opkg install libip6tc2
opkg install iptables
opkg install openwrt-keyring
opkg install openvpn-openssl
opkg install kmod-mt7663-firmware-ap
opkg install libubox20210516
opkg install jshn
opkg install kmod-ipt-core
opkg install ca-certificates
opkg install kmod-ppp
opkg install libiwinfo20210430
opkg install libjson-c5
opkg install uhttpd
opkg install kmod-nf-conntrack
opkg install usign
opkg install ip6tables
opkg install liblua5.1.5
opkg install kmod-nf-ipt6
opkg install luci-lib-nixio
opkg install ca-bundle
opkg install libuclient20201210
opkg install liblucihttp-lua
opkg install luci-lib-jsonc
opkg install luci
opkg install kmod-nf-conntrack6
opkg install kmod-usb-ledtrig-usbport
opkg install ubox
opkg install kernel
opkg install rpcd-mod-iwinfo
opkg install luci-mod-network
opkg install uhttpd-mod-ubus
opkg install fwtool
opkg install jsonfilter
opkg install hostapd-common
opkg install kmod-ipt-offload
opkg install wireless-regdb
opkg install urngd
opkg install kmod-slhc
opkg install rpcd-mod-rrdns
opkg install ppp-mod-pppoe
opkg install luci-app-openvpn