Kern.warn kernel dhcp request loop

I have a glinet router and i have modified the guest wifi network but now for some reason clients attached to my non guest network are constantly doing dhcp requests or openwrt dnsmasq is restarting constantly, i don't see this issue on my "iot" network.

Thu Jun 27 19:07:47 2024 kern.warn kernel: [ 2105.955725]
Thu Jun 27 19:07:49 2024 daemon.info dnsmasq-dhcp[25552]: DHCPREQUEST(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:49 2024 daemon.info dnsmasq-dhcp[25552]: DHCPACK(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS LAPTOP
Thu Jun 27 19:07:54 2024 kern.notice kernel: [ 2113.129796] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(0), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:54 2024 kern.notice kernel: [ 2113.146569] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647:  Recv Assoc from STA - LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:54 2024 kern.notice kernel: [ 2113.155892] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=0)...
Thu Jun 27 19:07:54 2024 kern.notice kernel: [ 2113.165007] 7981@C01L3,wifi_sys_conn_act() 1115: wdev idx = 0
Thu Jun 27 19:07:54 2024 kern.notice kernel: [ 2113.171054] 7981@C08L3,hw_ctrl_flow_v2_connt_act() 215: wdev_idx=0
Thu Jun 27 19:07:55 2024 kern.notice kernel: [ 2113.280879] 7981@C15L3,WPABuildPairMsg1() 5280: <=== send Msg1 of 4-way
Thu Jun 27 19:07:55 2024 kern.notice kernel: [ 2113.287565] 7981@C15L3,PeerPairMsg2Action() 6202: ===>Receive msg 2
Thu Jun 27 19:07:55 2024 kern.notice kernel: [ 2113.294338] 7981@C15L3,WPABuildPairMsg3() 5557: <=== send Msg3 of 4-way
Thu Jun 27 19:07:55 2024 kern.notice kernel: [ 2113.301065] 7981@C15L3,PeerPairMsg4Action() 6632: ===>Receive msg 4
Thu Jun 27 19:07:55 2024 daemon.info dnsmasq-dhcp[25552]: DHCPREQUEST(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:55 2024 daemon.info dnsmasq-dhcp[25552]: DHCPACK(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS LAPTOP
Thu Jun 27 19:07:55 2024 kern.warn kernel: [ 2113.313876] 7981@C15L2,PeerPairMsg4Action() 6994: AP SETKEYS DONE(ra0) - AKMMap=WPA2PSK, PairwiseCipher=AES, GroupCipher=AES, wcid=1 from LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:55 2024 kern.warn kernel: [ 2113.313876]
Thu Jun 27 19:07:57 2024 daemon.info dnsmasq-dhcp[25552]: DHCPREQUEST(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS
Thu Jun 27 19:07:57 2024 daemon.info dnsmasq-dhcp[25552]: DHCPACK(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS LAPTOP
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.557187] 7981@C08L3,ap_peer_auth_req_at_idle_action() 717: AUTH - MBSS(0), Rcv AUTH seq#1, Alg=0, Status=0 from [wcid=1]LAPTOP:MAC:ADDRESS
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.576272] 7981@C08L3,ap_cmm_peer_assoc_req_action() 1647:  Recv Assoc from STA - LAPTOP:MAC:ADDRESS
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.585578] 7981@C08L3,ap_cmm_peer_assoc_req_action() 2170: ASSOC Send ASSOC response (Status=0)...
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.594693] 7981@C01L3,wifi_sys_conn_act() 1115: wdev idx = 0
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.600733] 7981@C08L3,hw_ctrl_flow_v2_connt_act() 215: wdev_idx=0
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.711518] 7981@C15L3,WPABuildPairMsg1() 5280: <=== send Msg1 of 4-way
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.718209] 7981@C15L3,PeerPairMsg2Action() 6202: ===>Receive msg 2
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.724982] 7981@C15L3,WPABuildPairMsg3() 5557: <=== send Msg3 of 4-way
Thu Jun 27 19:08:00 2024 kern.notice kernel: [ 2118.731737] 7981@C15L3,PeerPairMsg4Action() 6632: ===>Receive msg 4
Thu Jun 27 19:08:00 2024 daemon.info dnsmasq-dhcp[25552]: DHCPREQUEST(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS
Thu Jun 27 19:08:00 2024 daemon.info dnsmasq-dhcp[25552]: DHCPACK(br-lan) 192.168.8.209 LAPTOP:MAC:ADDRESS LAPTOP
Thu Jun 27 19:08:00 2024 kern.warn kernel: [ 2118.744472] 7981@C15L2,PeerPairMsg4Action() 6994: AP SETKEYS DONE(ra0) - AKMMap=WPA2PSK, PairwiseCipher=AES, GroupCipher=AES, wcid=1 from LAPTOP:MAC:ADDRESS
root@GL-MT3000:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf3:600d:9e9e::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1'
        option macaddr ''

config device
        option name 'eth1'
        option macaddr ''

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.8.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option isolate '0'

config device
        option name 'eth0'
        option macaddr ''

config interface 'wan'
        option device 'eth0'
        option proto 'dhcp'
        option force_link '0'
        option ipv6 '0'
        option metric '10'

config interface 'wan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wan'

config interface 'tethering6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@tethering'

config interface 'wwan6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@wwan'

config interface 'wwan'
        option proto 'dhcp'
        option metric '20'

config interface 'modem_1_1_2_6'
        option proto 'dhcpv6'
        option disabled '1'
        option device '@modem_1_1_2'

config rule 'policy_direct_rt'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule 'policy_default_rt_vpn'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule6 'policy_direct_rt6'
        option lookup 'main'
        option suppress_prefixlength '0'
        option priority '1100'

config rule6 'policy_default_rt_vpn6'
        option mark '0x8000/0xc000'
        option lookup '8000'
        option priority '1101'
        option invert '1'

config rule 'policy_default_rt_vpn_ts'
        option lookup 'main'
        option priority '1099'
        option mark '0x80000/0xc0000'
        option invert '0'

config device
        option bridge_empty '1'
        option type 'bridge'
        option name 'br-iot'
        option ipv6 '0'

config interface 'iot'
        option device 'br-iot'
        option proto 'static'
        option ipaddr '192.168.100.1'
        option netmask '255.255.255.0'
root@GL-MT3000:~# cat /etc/config/dhcp
config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option rebind_protection '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ra_slaac '1'
        option force '1'
        option dhcpv6 'disabled'
        option ra 'disabled'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config domain
        option name 'console.gl-inet.com'
        option ip '192.168.8.1'

config domain
        option name 'console.gl-inet.com'
        option ip '::ffff:192.168.8.1'

config dhcp 'iot'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'iot'
        list ra_flags 'none'

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.