Keep getting isp routers gateway on client PC

@lleachii : I moved my DNS servers into the wan interface in Luci.

My config now looks like this:

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd39:af24:529d::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option ipaddr '10.74.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5t 3 2 1'

config switch_vlan
        option device 'switch0'
        option ports '5t 0'
        option vlan '2'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option delegate '0'

root@OpenWrt:/etc/config#

Looks better. Does it work?

1 Like

I don't see them...but OK...does your connection work?

If you added them, the config should appear:

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option delegate '0'
        option peerdns '0'
        option dns '1.1.1.1 1.0.0.1 8.8.8.8 8.8.4.4'

In the wan interface config on LuCI:

Screenshot from 2020-04-23 11-12-45

Oh yes my bad, i had not added the servers.

@psherman , Everything seems to be working as it should.

Thank you all for your amazing help, you are truly legends!
You have sparked my interest in networking and in OpenWrt in general.

What should i put as "The solution" here on the forum?

1 Like

Awesome!

As it turns out, the active participants on this thread are all frequent and eager contributors to the forum. We're here because we love this stuff and we enjoy helping people get through tough technical issues and helping people learn about OpenWrt. I can only speak for myself here (but I'll guess there is truth to this for the others)... I know I also learn things all the time by being part of this forum :slight_smile:.

Might be a bit tough because of the many iterations... but fundamentally, choose the 'solution' that you think a future reader might find the most useful (even if it isn't totally complete).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.