Kamikaze install to ASUS WL700-gE


I tried to create an own build and install it but something went wrong. But know idea what and how to fix it.
I know this is a very old and outdated router, but this is nothing else just a challange and learing for me.
Here is the details
make image PROFILE=WL700GE PACKAGES="base-files busybox dropbear kmod-diag kmod-fs-ext3 kmod-ide-aec62xx kmod-ide-core kmod-switch libgcc -kmod-ppp -kmod-pppoe -ppp -ppp-mod-pppoe -nvram -dnsmasq -iptables -kmod-ipt-nathelper -mtd e2fsprogs fdisk uci luci kmod-usb-uhci kmod-usb-ohci block-mount"

Boot info
ASUS Stock boot: https://pastebin.com/ZR9xPeuG
Kamikaze install process: https://pastebin.com/GFyR907d
Kamikaze boot: https://pastebin.com/dBPFHxps

root@OpenWrt:/# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00040000 00010000 "cfe"
mtd1: 001b0000 00010000 "linux"
mtd2: 000e2c00 00010000 "rootfs"
mtd3: 00010000 00008000 "nvram"
mtd4: 00050000 00010000 "rootfs_data"
root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root               896.0K    896.0K         0 100% /rom
tmpfs                    30.7M     36.0K     30.7M   0% /tmp
/dev/mtdblock/4         320.0K    320.0K         0 100% /tmp/overlay
root                    896.0K    896.0K         0 100% /tmp/root
mini_fo:/tmp/root       896.0K    896.0K         0 100% /tmp/root
/dev/mtdblock/4         320.0K    320.0K         0 100% /overlay
mini_fo:/overlay        896.0K    896.0K         0 100% /

root@OpenWrt:/# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro)
none on /dev type devfs (rw)
none on /proc type proc (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw)
/dev/mtdblock/4 on /tmp/overlay type jffs2 (rw)
root on /tmp/root type tmpfs (rw)
mini_fo:/tmp/root on /tmp/root type mini_fo (rw)
/dev/mtdblock/4 on /overlay type jffs2 (rw)
mini_fo:/overlay on / type mini_fo (rw)

Best Regards,

two things:
Why do you think something went wrong?
Get a new router!


Just to piggyback on what @rj-45 said... get a new router. It is simply not worth spending any time trying to use a router that is >10 years old -- it is too old and will have very little ram and flash space, and will certainly not be able to run any current version of OpenWrt. In practical terms, that means it will be slow, there will be numerous major security risks, it will have obsolete packages (if you can even download them anymore), and won't have anything that has been developed in the last 10 years!

Another major practical reason that you should not use this router is that you won't get any support for it, period. So much has changed between Kamikaze and anything recent (LEDE 17.05 through OpenWrt 19.07 just released) and honestly nobody is going to remember how to configure, debug, or even build such an old release.

New/used routers that can support the newest OpenWrt can be had for ~$20-30 USD.


Hardware specs: https://wikidevi.wi-cat.ru/ASUS_WL-700gE

2MB flash is by far not enough for OpenWrt.

See https://openwrt.org/supported_devices/432_warning for details.


Thank You those non value add comments.
Its old hw i know thats why i am trying with kamikaze. (8.09)

The #1 problem is that luci is not loading.
I wanted extroot but cannot reach ide disk nor usb

#get new router - this is for learning / challenging.

What did you think about this:

mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
mini_fo: build_sto_structure: failed to create storage dir [1].
mini_fo: get_neg_sto_dentry: ERROR building sto structure.

forget it!! it is like riding a dead horse! You can learn everything with a new router, too.
2mb flash, were always a challenge, even ten years ago.


Understand, this forum was my last hope.

Again to echo @rj-45's comments... still not worth learning/challenging on this. Even if you do get things running, you'd be learning a bunch of stuff where the specific details are both obsolete and not useful anymore. If you get a new(-ish) router and work with a current version (v18 or v19), you'll learn a lot and it will all be useful.

As an analogy, unless you are either a computer historian or looking for an extremely niche job, you wouldn't go learn COBOL, would you? You'd learn modern programming languages so that your knowledge is useful.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.