just installed x86 x64 rack, losing internet connection after hours of use, restart is the only solution
what could i do?
just installed x86 x64 rack, losing internet connection after hours of use, restart is the only solution
what could i do?
Post the log?
where is the log? cat /etc/log?
let's start by reviewing your configuration:
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@testprod:~# ubus call system board
{
"kernel": "5.15.137",
"hostname": "testprod",
"system": "Intel(R) Core(TM)2 Duo CPU E2500 @ 1GHz",
"model": "Dell Inc. OptiPlex 100",
"board_name": "dell-inc-optiplex-100",
"rootfs_type": "ext4",
"release": {
"distribution": "OpenWrt",
"version": "23.05.2",
"revision": "r23630-842932a63d",
"target": "x86/generic",
"description": "OpenWrt 23.05.2 r23630"
}
}
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd45:e5f2:ae70::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.56.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
config interface 'wan6'
option device 'eth1'
option proto 'dhcpv6'
root@testprod:~# cat /etc/config/wireless
cat: can't open '/etc/config/wireless': No such file or directory
root@testprod:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option localservice '1'
option ednspacket_max '1232'
option noresolv '1'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
root@testprod:~# cat /etc/config/firewall
config defaults
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
option synflood_protect '1'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'
option masq '1'
option mtu_fix '1'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include 'bcp38'
option type 'script'
option path '/usr/lib/bcp38/run.sh'
Have you checked that this isn't the source of the problem? Maybe you should disable this for now.
also my shadowsocks server is not working i would be glad if you could help me there too
shadowsocks not working despite everything is configured
will do, havent tought that, thx
in this case, since you have a bunch of things running on top of what would otherwise be a standard install, you should disable both of them and see if things remain stable. Then enable one and test again... and then turn that one off and turn on the other thing. This way you can begin to figure out if the problem is one of the additions or an interaction between them, or something more fundamental/basic.
that is what i am doing, for example i started with bcp+banip and had to discard banip because it was unstable for now i just have dns over https in the most simple way, which is stubby and have proven working on my 5 openwrt routers i got , however in x86 i always had this problem with openwrt for some reason it goes offline the internet and i have to reboot the pc
what is primordial for me is to try to getting working the shadowsocks server but despite i have done step by step word by word, it does not works, despite it says it is running, and in my phone is running ok, too
Have you run the x86 machine in a (nearly) default configuration? That should be the first test.
yes i did and it worked
So start there and then install only one additional package and test. Right now you have at least 2 (maybe more) packages that could materially affect the performance of your router, and we don't have any way to untangle them.
will do, thank you again,
if there is an error again will report, my priority is to make it work and if i find some bug or whatever like that help to get patched or try to find out patch it myself
then your first test should be to test the default config for at least 24 hours.
should i leave it open the ticket or close it? also could you help me debugg what is wrong with my shadowsock config if there is a possibility and if is not a hassle for you i am sorry i tried my best and despite checking everyone is successfull running the server, here i am having errors
Tackle one issue at a time. For now, just test the default configuration for 24 hours or more. You can leave this thread open and come back to it with results later.
As for shadowsocks, I have used it, but not in a long time and my use-case was a road-warrior type config where I controlled both sides. I set it up to serve as a method to obfuscate OpenVPN connections. But I'm not really going to be all that useful in setting it up for any other purposes or use-cases.
okay friend will do, that is what i am trying, just trying to route all traffic thru a shadowsock server so my data could not be intercepted that easily , and i think is better to config the main router as a big wall encrypting everything so i dont need to config client per client all the other devices, shall we talk about it here or in the thread i created for it? and sorry for bombarding with so many errors in a short period of time, i am newbie on it and i am just trying to configure everything and leaving it running correctly so i can progress and do my job
i think i found the culprit of the system crash
apparently shadowsocks is having a crash loop it restarts, crash and repeat
since reboot there are 17 crashes
Wed Dec 13 06:00:41 2023 daemon.info procd: Instance shadowsocks-libev::ss_server.cfg07eca1 s in a crash loop 17 crashes, 0 seconds since last crash
certainly looks like a good indication of a problem there. remove shadowsocks and see if that fixes your issues.