Just installed OpenWrt 18.06.0-rc1 on TP-LINK TL-741nd version 4.22

It booted and seems to be running fine. Space is a bit tight : only 76k flash free with my smallish scripts loaded.

Boot log except and free info below.

 OpenWrt 18.06.0-rc1 r7090-d2aa3a1b62 / LuCI openwrt-18.06 branch (git-18.163.60998-c379f00) 

[    0.000000] Linux version 4.9.109 (buildbot@builds-03.infra.lede-project.org) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6984-fa0275b) ) #0 Thu Jun 21 05:02:51 2018
[    0.000000] MyLoader: sysp=4cc15e57, boardp=635a7dca, parts=0c7b9213
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR9330 rev 1
[    0.000000] Determined physical RAM map:

[    0.000000] Kernel command line:  board=TL-WR741ND-v4  console=ttyATH0,115200 rootfstype=squashfs noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 27660K/32768K available (3356K kernel code, 159K rwdata, 424K rodata, 212K init, 219K bss, 5108K reserved, 0K cma-reserved)

             total       used       free     shared    buffers     cached
Mem:         27872      23312       4560        488       2224       7652
-/+ buffers/cache:      13436      14436
Swap:            0          0          0


is there for a reason. With 76 kB of flash free, you may find yourself unable to change the contents of flash if it fills much more (a certain number of free "erase blocks" are required to make changes). 4 MB of free RAM isn't all that comforting either.

Hi Jeff. Thanks for the tip on the need for flash space. I believe that flash blocks are 64 k so it looks like only 1 block would fit in 76k.

I tried adding another wireless interface and this seems to have worked, but dropped free flash space to 72k. So there is not a lot of room to work with. But at least I did not get an "out of space" error.

As far as RAM, my "available memory" on LEDE 17 was 11916 , now with RC-1 its 12116, essentially little changed since this number is going to be fluctuating regularly depending on system load.

I was able to roll back to stable LEDE release 17 with no drama.

I am eagerly awaiting the next 18.0.6 release candidate to test.