Just another no internet connection thread

Hello everybody,
I have flashed a AVM Fritzbox 4040 with newest verison of OpenWrt recently. I intend to use it behind my Fritzbox 6890 as a firewall-router. So far, I have configured static routes on the 6890 to the network behind the 4040, and the ping command in both directions works.
Unfortunately, as stated in the title, it is not possible to get a connection established outside the 6890.

Here is an artwork of my network:

Please feel free to ask for further information.

Thank you in advance.

ps: screenshot of OpenWrt interface settings follows

Here my interface settings in OpenWrt:

I forgot to mention, NAT is already deactivated on 4040.

Does the 6890 have a static route to 192.168.200.0/24 via 192.168.7.5 installed?

1 Like

Yes it does, please have a look:

Check from OpenWrt and PC:

traceroute openwrt.org

Thanks for your answer.

traceroute on the notebook returns: unknown host
traceroute in the diagnostic tool on luci returns: bad address

nslookup openwrt.org
nslookup openwrt.org 8.8.8.8
nslookup openwrt.org 192.168.77.19

https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#upstream_dns_provider

Changed the DNS-Servers in the Pihole Admin Webinterface as well:

Both should support DNSSEC now.

Referring to your link, where in luci can I put this:

Configure DNS provider

uci set network.wan.peerdns="0"
uci set network.wan.dns="8.8.8.8 8.8.4.4"
uci set network.wan6.peerdns="0"
uci set network.wan6.dns="2001:4860:4860::8888 2001:4860:4860::8844"
uci commit network
service network restart

Replace Google DNS with your own DNS:

uci set network.wan.peerdns="0"
uci set network.wan.dns="192.168.77.19"
uci set network.wan6.peerdns="0"
uci set network.wan6.dns=""
uci commit network
service network restart
1 Like

On your OpenWrt router, you need to set the WAN gateway to 192.168.77.1 and the WAN DNS to 192.168.77.19.

This is necessary whenever you static IP the WAN.

3 Likes

@vgaeteraThank you again for your answer, separate from that with the recommendation from mk24 now everything works, the commands in your post are cli commands, or?

1 Like

https://openwrt.org/docs/guide-user/base-system/uci#command_line_utility

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.