Join multiple wifi network using WDS at the same time

My router is TP link c6 which is a dual band router.

My requirement is:
I want to join multiple wds Wi-Fi network using 5 Ghz and 2.4 Ghz channel at the same time.
afterwards merge all the Wi-Fi signal into one and transmit the merged signal using by router's 2.4 Ghz and and 5 Ghz channel .

make sure beam-forming technology is available.
Also mesh technology also available .

Is it possible using open WRT?

Can you better describe this?

This?

Yes, join multiple wds Wi-Fi network (2.4 Ghz and 5Ghz Band).
Combine the 2.4 GHz and 5Ghz network Band's signal.
And the output is Two BSSID.
One is 2.4 Ghz band and the other is 5 Ghz band.

Not possible on any currently supported hardware, which allow only a single STA interface at any given time. You will have to either go wired with multiple VLANs or push the network distinction a level higher (e.g. via GRE tunnels).

1 Like

Thanks for your response.
I asked the same question to chat GPT. The language model answered me it is possible.

Then you also should have asked it how to do it ...

1 Like

From a few days Chat GPT was telling it is possible. Suddenly today said merging 2.4 Ghz channel and 5 ghz channel is not possible.
So i modified my requirement as bellow.

My router is TP link c6 which is a dual band router.
I want to join multiple wds wifi network using 5 ghz and 2.4 ghz channel at the same time.
afterwards merge all the 5 ghz signal into one and and transmit the merged signal using by router's 5 ghz channel .
And merge all the 2.4 ghz signal into one and transmit the merged signal using by router's 2.4 ghz channel .

My SSID name is
For 2.4 Ghz channel : Home_2.4 ghz, pasword : my password, MAC: 74:E8:XX:B1:FD:XX
For 5 Ghz channel : Home_5ghz, pasword : my password, MAC: 74:E8:XX:B1:XX:60

make sure beam-forming technology is available.
Also mesh technology also available .

Here is the AP list to be connect using WDS

AP name : Parent AP1
password: Parent AP1 Password
MAC: XX:E8:94:XX:FD:XX
channel : 5Ghz

AP name :Parent AP2
password: Parent AP2 Password
MAC: XX:9A:4A:XX:F8:XX
channel : 5Ghz

AP name : Parent AP1
password: Parent AP1 Password
MAC: XX:E8:94:XX:FD:XX
channel : 2.4 Ghz

AP name :Parent AP2
password: Parent AP2 Password
MAC: XX:9A:4A:XX:F8:XX
channel : 2.4 Ghz

AP name : Parent AP3
password: Parent AP3 Password
MAC: XX:8B:XX:47:F9:XX
channel : 2.4 Ghz

** For doing this on open WRT Give me the full SSH command . i will copy the command and paste into putty. So, give the full command as required in one screen.

-------------- and Chat GPT answered me -------------

To achieve your desired setup, you can follow these steps on OpenWRT:

  1. Connect to your router via SSH using a program like PuTTY.
  2. Install the necessary packages by running the following command:

opkg update && opkg install wpad-mesh-openssl wpa-cli

  1. Configure your wireless settings by editing the wireless configuration file using the following command:

vi /etc/config/wireless

  1. Add the following configuration to the file:

config wifi-iface 'wifinet0'
option device 'radio0'
option network 'wlan0'
option mode 'sta'
option ssid 'Parent AP1'
option key 'Parent AP1 Password'
option encryption 'psk2'
option bssid 'XX:E8:94:XX:FD:XX'
option wds '1'

config wifi-iface 'wifinet1'
option device 'radio0'
option network 'wlan0'
option mode 'sta'
option ssid 'Parent AP2'
option key 'Parent AP2 Password'
option encryption 'psk2'
option bssid 'XX:9A:4A:XX:F8:XX'
option wds '1'

config wifi-iface 'wifinet2'
option device 'radio1'
option network 'wlan1'
option mode 'sta'
option ssid 'Parent AP1'
option key 'Parent AP1 Password'
option encryption 'psk2'
option bssid 'XX:E8:94:XX:FD:XX'
option wds '1'

config wifi-iface 'wifinet3'
option device 'radio1'
option network 'wlan1'
option mode 'sta'
option ssid 'Parent AP2'
option key 'Parent AP2 Password'
option encryption 'psk2'
option bssid 'XX:9A:4A:XX:F8:XX'
option wds '1'

config wifi-iface 'wifinet4'
option device 'radio0'
option network 'wlan0'
option mode 'ap'
option ssid 'Home_5ghz'
option encryption 'psk2'
option key 'my password'
option macaddr '74:E8:XX:B1:XX:60'
option wds '1'

config wifi-iface 'wifinet5'
option device 'radio1'
option network 'wlan1'
option mode 'ap'
option ssid 'Home_2.4ghz'
option encryption 'psk2'
option key 'my password'
option macaddr '74:E8:XX:B1:FD:XX'
option wds '1'

Note: replace XX with appropriate values for the MAC addresses.

  1. Save the changes and exit the editor by pressing ESC then :wq.
  2. Restart the network by running the following command:

/etc/init.d/network restart

Once you have completed these steps, your router should be able to join the
multiple WDS networks using both 5GHz and 2.4GHz channels and transmit the
merged signals through the router's 5GHz and 2.4GHz channels respectively.
The beam-forming technology and mesh technology should be available as well.

Brah, you are smarter then ChatGPT. Come on.

1 Like

implement it, and let us know how it pans out ...

Actually i am looking for expert opinion.:smile:

so you went to Chat GP ?

:+1:

1 Like

:laughing: this is hilarious

This literally appeared below in the suggested answers.

3 Likes

I made the post for expert review.

Why would we review something that's not doable ?

If you trust us less than chat gp, implement the config, our answer stands.

If it crashes, please ask chat gp how to fix it.

Dear frollic,
Then you could write a line "that's not possible" for me.

it was done yesterday already

1 Like

You do realise it does not know anything, right? It's just code crunching data with an advanced language model. It cannot discern between truths and falsehoods.

But hey, ask ChatGPT to deliver the solution, then you don't need to open threads on the OpenWrt forum. We're not in the chatbot feeding business here.

Dear everyone,

I would like to express my gratitude for your responses.
I created this thread because I am a new user of OpenWRT.
I was feeling confused and needed guidance from experts like you, to make an informed decision before taking the CHAT GPT solution.
I hope that you all understand my situation and I am grateful for your time and effort in helping me.

Once again, Thank you for your support and for sharing your knowledge and experience with me.

1 Like