JFFS2 Problems [Solved]

Access Point WA901ND v5 Openwrt 18.06.2
I need to write wireless file but it lock to readonly mode can I do something to make more space
one package I need in this project is openssh-sftp-server how can I fix this problems .

Your device does not have sufficient flash to be able to load all the packages you have on it.

"Deleting" packages that you did not install will not reclaim any space.

You will likely need to create a custom build, either assembling packages with the image builder, or srom source using the build system. Removing LuCI would be the first step I would take.

Even if you do this, you may not have sufficient RAM for stable operation.

https://openwrt.org/docs/guide-user/additional-software/imagebuilder
https://openwrt.org/docs/guide-developer/build-system/start

Note that v17 is about to be EOL-ed, so purchase of a device with sufficient resources (16 MB flash, 128 MB ram, for single-radio devices) is strongly suggested, especially for secure operation. They start at under US$20.

1 Like

Thank You
expand me about image builder please I don't know about it much it like we make software on Internet and download it ?

It is explained on the page I linked. You will need a running Linux-based OS, like Debian. It can be run on a VM. You will build your own software on your own desktop/laptop.

See https://openwrt.org/docs/guide-user/additional-software/saving_space for some hints as to what you can remove.

A new device that costs little more than a couple of drinks would be much easier and probably provide better service to you in the future. Your current device may not be supported at all shortly.

1 Like

ok now I can make image and config it but how can I install openssh-sftp-server without update openwrt ?

I can do it forgot to config dns It work fine now thank all of you so much

1 Like

@codeanon If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)