It is possible to run OpenWrt @ Alfa Network R36AH?

did anybody got openWRT running at Alfa Network R36AH?
I am not sure what the difference to the R36A is?

Kind regards

Hi @Userin1974

As far as I know, the only differences between R36AH and R36A is extra USB HUB chipset (Terminus FE1.1) and LED connector header in R36AH. You can use R36A image on the R36AH.

1 Like

Tanks, after some trial and error I got the latest openWRT release ( 19.07 ) at the R36AH.
I bought a 4G CampPro 2+ set (R36AH + Tube-U4Gv2), works well but has no OpenVPN :wink: .

With the default firmware I had some trouble, if I tried to install it directly via the web GUI I got this error:
"image invalid"

The "web recovery mode in U-Boot" mentioned here:;a=commit;h=af8f0629df080bb057dea6cc77a1faacc648ae0d

did not work (the LAN LED didn't glow).

With this firmware from files alfa com tw "web recovery mode in U-Boot" isn't working:

  • FW_4GCampPro2Plus_v0.4-GB_20190306.bin
  • FW_R36AH_v1.0-GB_20191028_alfa.bin

But with the older firmware version " FW_R36AH_v0.2-GB_20190102_alfa.bin" "web recovery mode in U-Boot" is working. :slight_smile:

The Tube-U4Gv2 USB QMI LTE modem works also well this way:

Kind regards

How did you manage to install openWRT on your R36AH finally ?

I have Tube-U4Gv2 with R36A and want to install openWRT because I would like to do load balancing (using mwan3 package) between 4G WAN and ethernet LAN.

install this Image:[2]%20WiFi%20Home%20Router/R36AH/FW_R36AH_v0.2-GB_20190102_alfa.bin

After this step, this will work:

You can use sysupgrade image directly in vendor firmware which is based
on LEDE/OpenWrt. Alternatively, you can use web recovery mode in U-Boot:

  1. Configure PC with static IP
  2. Connect PC with one of RJ45 ports, press the reset button, power up
    device, wait for first blink of all LEDs (indicates network setup),
    then keep button for 3 following blinks and release it.
  3. Open address in your browser and upload sysupgrade image.
    (Source:;a=commit;h=af8f0629df080bb057dea6cc77a1faacc648ae0d )

Where can I find or who can tell me which USB adapters or chipsets are supported by open WRT on a ALFA R36AH?

The USB Port of the Alfa R36AH has more power than the ALFA 121u.
With the Alfa 121u I used a HUAWEI E3372 (kmod-usb-net-cdc-ether/usb-modeswitch), but there a active USB HUB was needed to get it stable working.
I didn't test the HUAWEI E3372 with the R36AH, but should word now without additionally voltage.

For ore information look here:

sorry, I meant WiFi-USB adapters

Did you make it work? I tried everything but something I am doing wrong... It detects the Tube but never connects...

Note: new alphas today for the camp-pro 4g 2+[7]%20CampPro/4G%20CampPro%202%2B