Issues with Switch Ports on Realtek RTL9303 (XikeStor SKS8300-8X)

I'm having trouble getting the switch ports to work on my XikeStor SKS8300-8X switch using the newly commited OpenWrt. I followed the installation steps for the Realtek RTL9303 chip (commit hash: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=0dc0b982950a3e471862925ff1ca5a78d9515821) using files from here https://downloads.openwrt.org/snapshots/targets/realtek/

The goal was to simply convert the SKS8300-8X to a simple OpenWrt switch to start with, then layer more on. The switch seems to be recognized by the system, but the individual ports are not functioning (showing as DOWN in ip a). I've tried updating drivers and checking the hardware, but the issue persists. Only port 1 shows link with status up but not pingable.

I've attached the logs from dmesg, ip a, and the network file for reference.

Any help or guidance on troubleshooting this issue would be greatly appreciated.

root@OpenWrt:/etc/config# dmesg | grep switch
[   14.885232] rtl83xx-switch switch@1b000000: configuring for fixed/internal link mode
[   15.099973] rtl83xx-switch switch@1b000000 lan1 (uninitialized): PHY [mdio-bus:00] driver [REALTEK RTL930)
[   15.251883] rtl83xx-switch switch@1b000000 lan2 (uninitialized): PHY [mdio-bus:08] driver [REALTEK RTL930)
[   15.403835] rtl83xx-switch switch@1b000000 lan3 (uninitialized): PHY [mdio-bus:10] driver [REALTEK RTL930)
[   15.555920] rtl83xx-switch switch@1b000000 lan4 (uninitialized): PHY [mdio-bus:14] driver [REALTEK RTL930)
[   15.707839] rtl83xx-switch switch@1b000000 lan5 (uninitialized): PHY [mdio-bus:18] driver [REALTEK RTL930)
[   15.859674] rtl83xx-switch switch@1b000000 lan6 (uninitialized): PHY [mdio-bus:19] driver [REALTEK RTL930)
[   16.011564] rtl83xx-switch switch@1b000000 lan7 (uninitialized): PHY [mdio-bus:1a] driver [REALTEK RTL930)
[   16.163376] rtl83xx-switch switch@1b000000 lan8 (uninitialized): PHY [mdio-bus:1b] driver [REALTEK RTL930)
[   16.871956] rtl83xx-switch switch@1b000000: Link is Up - 10Gbps/Full - flow control off
[   23.971312] rtl83xx-switch switch@1b000000 lan1: configuring for inband/10gbase-r link mode
[   39.961468] mount_root: switching to jffs2 overlay

root@OpenWrt:/etc/config# ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc mq state UP qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::2e0:4cff:fe00:0/64 scope link 
       valid_lft forever preferred_lft forever
3: lan1@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
4: lan2@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
5: lan3@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
6: lan4@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
7: lan5@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
8: lan6@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
9: lan7@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff
10: lan8@eth0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:e0:4c:00:00:00 brd ff:ff:ff:ff:ff:ff

root@OpenWrt:/etc/config# cat network 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9b:d11700d1:9b72009b::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1 eth2 eth3 eth4 eth5 eth6 eth7 eth8' 

Have a look in the rtl thread - we're discussing exactly this hardware there.

1 Like

I spent quite a bit of time troubleshooting on my own, with a little help from ChatGPT along the way. While we made some progress, it often felt like there wasn’t much to show for it.

Frustrated with the lack of clear progress, I decided to reinstall everything from scratch. One thing I’m still not sure about is whether the OpenWrt snapshots are rebuilt as frequently as their dates suggest. From the results, I'd say they are updated!

To my delight, after the reinstall, I now have a XikeStore SKS8300-8X running OpenWrt with a single VLAN and all the ports functioning as expected! The only change I made was adjusting the static IP in the network file to a static DHCP address on my home network and restarting the networking service.

A couple of things to be aware of if you decide to follow this path:

  1. I installed LuCI just for the convenience of having a GUI to manage the switch. The web interface loaded fine at first, but as I navigated through various menus, it froze completely. Nothing worked. Thankfully, a reboot restored functionality, though I encountered the same issue again when using LuCI. Another reboot fixed it, and after that, everything was fine. For my purposes, though, I found that the CLI in OpenWrt works perfectly fine for managing the switch.

  2. The second issue is related to the DAC cable I initially used to connect the switch to my network. It worked without issue, despite being one of the cheapest available. However, when I tried to use mid-range 10GBase-T SFP devices, I ran into trouble. These were from the brand Alwong (purchased on Amazon), and unfortunately, they didn’t work at all. This caused part of the original debugging process to drag on. My recommendation is to test any SFP devices you plan to use on the specific gear first, so you don’t waste time troubleshooting. The brand that did work for me was Luma, though they are priced a bit higher.

A couple of final thoughts:

  • Using this fanless switch has been great in my office—no noise at all. However, the top of the case would often reach 105°F. If you’re looking for a solid 10G switch, the XikeStor 4x4 Switch (with 4x 10GBase-T ports and 4x SFP+ ports) might be a better option. It was around $200. The 8-port SFP+ version was just under $100, but once you factor in the cost of higher-end 10GBase-T SFP optics, the 4x4 switch becomes more cost-effective. It has a fan, but using mostly non-SFP+ ports keeps the power load low, so the fan rarely kicks on.

From reading other notes, I see that the SFP+ issue is very real.

The version that worked for me was a Luma SFP-10G-T-LU.

Not sure if relevant but the ones that didn't work were multspeed ones. That is, 1g, 2.5g, 5g and 10g.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.