Issues with OpenWrt on GL.iNet GL-MT300N-V2

Hi There,

I have the following issue when running OpenWRT on a GL.iNET GL-MT300N-V2:

ldconfig not available as a package to install


I have a weather station FineOffset WH1080 and I run weewx on the GL-MT300N-V2 to collect every 5 minutes the latest weahter data and process it.

As documented on the OpenWrt page there is no stable OpenWRT version available for my device but only a snapshot.

No almost everything is fine except the fact that ldconfig is missing and I couldn't figure out, how to get ldconfig installed.

I had to manually modify the driver module of weewx to overcome the missing ldconfig.

So I have the following questions:

  1. Where or how could I get ldconfig working on my OpenWRT?
  2. When could I expect a stable version of OpenWRT/Lede available for my GL-MT300N-V2?

I'm looking forward to any useful support!

Best regards


Interesting community, where it seems more important where in the word openwrt the capital letters are than to provide simple answers for a simple question...

You should always consider that nobody knows the answer to your question.
Or that nobody is interested in your question.
Or that not everybody has seen your question yet since mother earth didn't make a full rotation yet.

Perhaps if you had spent the time to describe your situation in some detail, you would have gotten help. Needless to say, your Chinese weather station with known problems in its firmware isn't a common piece of hardware to connect to a router. (Especially a package that consists of around 8,500 lines of "pure Python" code.)

Since weewx is not a package that is supplied by OpenWRT's feeds, you've pretty likely gotten the package elsewhere. That you've had to modify the driver suggests that you've got some competence with software. Perhaps you should look into why you're trying to run a utility that isn't part of the core OS that you're running on and how everyone else is able to do dynamic loading without ldconfig. Past that, why don't you ask the author/maintainer of wherever you got the driver for the weewx software?

Hi Jeff,

Many thanks for your reply! Yes I have some competence to read documentationa nd follow manuals. That is the way I followed to

  • extend storage capacity on my device with a thumbdrive and extroot
  • install python on the device
  • install some required additional packages for python form their python source
  • install des weewx software itself

I even overcame the issue of the missing ldconfig.

However I would consider ldconfig as a sort of basic component for a Linux-like operating system and I'm surprised, that I couldn't find an easy way to get it on my version of lede/openwrt. therefore my question here.

So if you or anyone else form the lede/openwrt community could answer one or the othe rof my two questions I'd be quite grateful.

  • Is there any hint or idea, how I get ldconfig on lede/openwrt?
  • Any idea when a stable version of lede/openwrt would become available for my device or a source where I find further information about such kind of information?

And what do you mean in particular with "driver for the weewx software"?

The link around the 18.06 schedule was already posted above.

ldconfig is for managing links and caches for dynamically loaded libraries ("configure dynamic linker run-time bindings"). It's not required for a Linux-based system to use that framework to manage dynamic libraries. Consider that many are still trying to run OpenWRT on devices with 4 MB of flash (or 8 MB, for that matter) and some of the reasons to omit "convenience" tooling can be seen in a different light.

Why a "pure Python" program would need to deal with dynamic libraries is a great puzzle. Hence the guess that the driver for your device for weewx was compiled and needed to be dynamically linked to something.

One should note that the real problem isn't ldconfig, but to tell weewx where to find libusb.!topic/weewx-user/sY5TJijPPv8

1 Like

@tmomas: what do you want to suggest with you post?

The issue you found on the net is solved. For me individually. However it is not generically solved as the issue is, how an aebitrary application which reads from either USB or serial ports finds the relevant shared libraries.

A common way is the usage of ldconfig. ldconfig was available in older versions of OpenWRT and is not in the snapshot I've installed.

Instead of discussing now wether or not ldconfig is important I would have expected from you experts a more solid feedback for instance
a. ldconfig is not required any more because there are the following better methods for applications to detect where to find necessary shared libraries
a.1 ...
a.2 ...
a.3 ...
b. oh it seems that lfconfig is missing the snapshot I have used but one could expect that it will become available with the next stable release

And if you guys can't imagine that a small router like the GL.iNET GL-MT300N-V2 is sort of an ideal mini computer to fetch continously (24x7) weather observations every 5 minutes from a personal weather station, to store the data in a sqlite database and compile the data into a website as well as publishing them at various weather networks, then there is not so much I can do about it.


I wanted to suggest to look at your problem from a different angle. Nothing more.

I can very well: I had a WS2300 + DS9490 + 8x 18B20 + THPL fed into a rrd database on a DIR-505 in use for quite a while. A WS2300 + DIR-505 is still in use today.

Discussion is continued in [SOLVED] Ldconfig missing on OpenWRT/LEDE, therefore closing this topic now.