Issues with mesh

Hi fellow openwrt lovers,

I have trouble getting mesh to work at my parents'.
We have an Archer C50 router and a Fritz Repeater 1200 over there and both are on the latest 21.02.1 release.
I have 2 SSIDs on each of them (one on 2.4 GHz and one on 5 GHz each). The AP WIFIs have the same SSIDs and passwords and clients have no problem connecting to either of them.
I have then tried to add a mesh WIFI, which looks like this (just the radio names are switched on the 2 devices):

config wifi-iface 'mesh'
        option device 'radio0'
        option mode 'mesh'
        option encryption 'sae'
        option key 'xyz'
        option mesh_fwding '1'
        option mesh_rssi_threshold '0'
        option mesh_id 'xyz'
        option network 'lan'

The mesh connects successfully. When then connecting to the repaeters WIFI, I am able to access the internet and other devices on the network. But a bit (maybe a minute?), there is a drop to zero connectivity (zero data transmission). After like 10-20 seconds, the network starts working again for a minute or so and then the same problem appears again.
I have tried both radios, first on 5 GHz and then later on 2.4 GHz, but they show the same behaviour.

Other settings on the repeater are, that I added the routers ip under DNS forwardings (DHCP and DNS) and that I added the routers IP as Gateway and DNS for the LAN network.

By connecting both via LAN, all traffic works as expected when using the repeaters WIFI networks. However there is no cable connection available where the repeater is planned to be located. Which is why I thought of using mesh.

To me it looks like sth. is breaking the routing now and then?
Does anyone have an idea?

Do I need to use a seperate network for mesh, like thy advice in the wiki?
However I tried that a few days ago. Just using a new network and puttting into the lan bridge and firewall profile, but not changing any settings on it.

edit: I tested again to give the mesh WIFI its one network and add that network to the LAN-bridge.
Neither with firewall set to unset or LAN for this network, there is no data flow and ping possibility between the mesh devices, though the mesh is connected.
Would I need to manually configure that mesh network instead of having it set to Protocol: unmanaged?

This article also mentiones to add the mesh WIFI directly to the LAN interface:
So currently my Mesh WIFI sits on the LAN bridge directly.
I have added my travel router (GL-AR300M) to the mesh and removed the router and then the repeater from the mesh to see if one of the devices just has an issue with its config or driver, but nothing changed.
Interestingly I can access the internet and ping the router from a client connected via the travel router (with static ip), but I can't ping any client connected to the router and vice versa. (Also pinging is not 100% successful; I get 1-2 % packet loss when running a ping for multiple minutes).
So I suspect something might be wrong with the default mesh routing protocol, which also would explain, why I can't get an IP from DHCP when connected to the WIFI of the repeater/travel router.
I use wpad-mesh-wolfssl on all 3 devices.

Does anyone have an idea what could be wrong?

Clients on the repeater can't ping or access clients on the router, but the other way around is working sometimes.
DNS from clients on the repeater is sometimes really slow and also websites load really slow.