Hi there,
i am trying to get an instance of OpenWRT x86 running as a VM on Proxmox to act as a router for other VMs. The server is hosted at Hetzner Germany. The configuration of the server itself and Proxmox is fine, since i already had a pfSense VM acting as the router - but i want to migrate to OpenWRT, i have better knowledge there. I am mentioning this because this is making me sure that this issue is purely on OpenWRT side.
IPv4 is running fine. I followed this excellent tutorial to set it up. The same author has written a second tutorial to use IPv6 with pfSense. As i mentioned, i was successful with it, but have trouble getting this to run on OpenWRT.
So, for now this is my configuration:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd5a:dbd2:3c24::/48'
config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '10.10.10.1'
config interface 'wan'
option ifname 'eth1'
option proto 'dhcp'
config interface 'wan6'
option ifname 'eth1'
option proto 'dhcpv6'
option reqaddress 'force'
option reqprefix '64'
If everything would have gone well, i would have gotten a second link-local IPv6 on wan, where my route is at, and i would be able to specify my subnet on lan and be able to ping. However, i only have the default link-local address. I do not know how to implement the options which are mentioned in the blogpost above:
- Request only an IPv6 prefix (i played with
option reqaddress
) - Send IPv6 prefix hint (what's the equivalent for this on OpenWRT?)
- Use IPv4 connectivity (what does this even mean?)
Currently the only result i get is this line in the logs: Wed Nov 28 20:44:52 2018 daemon.err odhcp6c[29573]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Of course i googled it and found some hints that it could have something to do with duplicate-address-detection. But as far as i see, all interfaces are up and running. Help, please?