Issues with DHCP and ip to clients, when multiple interfaces is used

Hi guys.

I’m struggling a bit with the last part of my network setup with OpenWrt. I hope this is just me overlooking something here. The thing is, when I have both the 2G and 5G wifi enabled (radio0 and 1) at the same time, I just seems that it will not give any IP thru DHCP. If I disable one of the radios it will give me an IP. What I also see in ifconfig, is that the IP range is not defined when both radios are enabled

wlan0 Link encap:Ethernet HWaddr BC:AE:C5:EB:8B:5F
inet6 addr: fe80::beae:c5ff:feeb:8b5f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1920 (1.8 KiB)

And If I disable radio 1 the IP comes up

wlan0 Link encap:Ethernet HWaddr BC:AE:C5:EB:8B:5F
inet addr:192.168.80.13 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::beae:c5ff:feeb:8b5f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1107619 errors:0 dropped:1654 overruns:0 frame:0
TX packets:718898 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000

I have tried all sort of settings, toogle brigde on/off, but it just doesn’t seem that I can get the DHCP to work proper. What am I missing here

Thanks a bunch!

network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd26:d085:64e2::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '8t 0 1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '8t 4'

config switch_vlan
	option device 'switch0'
	option vlan '10'
	option ports '8t 2'

config switch_vlan
	option device 'switch0'
	option ports '8t 3'
	option vlan '20'


config interface 'guest'
	option proto 'static'
	option ipaddr '192.168.80.1'
	option netmask '255.255.255.0'
	#option type 'bridge'

wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'HT20'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'platform/10180000.wmac'
	option htmode 'HT20'
	option noscan '1'

config wifi-iface 'wifinet2'
	option ssid 'Guest'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'ap'
	option key '---'
	option isolate '1'
	option network 'guest'

config wifi-iface 'wifinet3'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'ap'
	option key '----'
	option ssid 'Guest'
	option isolate '1'
	option network 'guest'

dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'guest'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'guest'

Should be on.

In fact, what you are trying to do should work out of the box without you having to do anything (except turning WiFi on and setting their security settings).

What kind of device you have? How many ports?

Hi mhegab.

Thank for your swift reply! OK, so the Bridge interfaces is on - selecting wlan0 (guest) and wlan1 (guest). Still the same issue:(

Its a RT-56U. 4 ports + 1 WAN port - off by one in the counting.

Can I try something else? I have tried to bridge a lan port as well, but it just doesn't work. The issue I can see in ifconfig that the IP is not allocated when bridging, can I just that for some sort of troubleshooting?

How about the other non-guest WiFi's? Do they work?

I can't understand how you can have port number 8! Are you able to post an image of your switch config on LuCI?