Issues Upgrading WRT1900ACS

Hey Guys -

Up until now, I've been using the David502c images, but they have seemingly gone away for a while. Having had intermittent wifi issues recently, I decided to upgrade to the latest stable (21.02.0-rc3) using the sysupgrade bin (version details below). When attempting this via LUCI or ssh, I got the below warning:

Device linksys,shelby not supported by this image
Supported devices: linksys,wrt1900acs armada-385-linksys-shelby linksys,shelby - Image version mismatch: image 1.1, device 1.0. Please wipe config during upgrade (force required) or reinstall. Reason: Config cannot be migrated from swconfig to DSA

I researched and what I read said it would be fine to proceed by forcing it, but not saving the config. I did so (via ssh) but after the reboot, got nothing. Tried power cycling again a couple of times - waiting a few minutes in between, but no DHCP pickup. Eventually, I found a method to switch to my 2nd partition by power cycling 3 times which brought it back up for now (to the same OpenWRT version & similar config as previously used), but don't know how to proceed with fixing for good and bringing it to the newest version.

  • Device: Linksys WRT1900ACS
  • Currently Installed IMG: OpenWrt SNAPSHOT r11159-27bf8abe69 (David502c build)
  • IMG Attempted to Flash: openwrt-21.02.0-rc3-mvebu-cortexa9-linksys_wrt1900acs-squashfs-sysupgrade.bin
  • Kernel: 4.19.76
    Note: I downloaded the IMG via wget + verified via sha256 prior to flashing


You mean you tried flashing without keeping settings, right?

It looks very weird to me that the custom master snapshot you were using would not be using DSA, but I have no idea how old it is, and at what point mvebu got DSA support.

Try to get serial hooked up to see what's going on, I remember there being issues with some WRT Linksys devices with newer kernels, but that sounded like it was 5.10 being too big, not 5.4 etc. (21.02 will use 5.4).


I did it here on a WRT1900ACS v1. You must wipe config and force upgrade.
You may start first with a stable 19.07.7 and then to 21.02 RC3 ?

The only thing that I noticed was a Mac address swap but it should not be an issue at first boot.

21.02.0-rc changed the partition table and settings will not migrate. Lots of DSA issues in RCs, thus you might want to stick with 19.07.7

There is no partition (kernel reservation space) change on the shelby (only mamba and venom). DSA works just fine if you do not keep config, which the OP states was the case.

Thanks Guys -

As mentioned, I choose not to keep the config when attempting flash in both LUCI & SSH. Unfortunately, it's my house's primary router so will have to program a spare and swap it out so I can work on more.

The issue I was having which prompted the upgrade was with WiFi as bandwidth starts crawling after 3-4 days yet fixed by rebooting. Assumed it would be something with the drivers and that the latest build may had rectified or included later ones. Another reason for the upgrade is that I've had my opkg sources set to use David502c's but with it offline, switched back over to the defaults. Once done & updated, I noticed that 277 of my 334 installed packages have updates available. Below are the versions of the wifi firmware currently installed and seem to be the latest...

  • mwifiex-sdio-firmware 20190815-1 ~877.0 KB Marvell 8887/8997 firmware
  • mwlwifi-firmware-88w8864
  • mwlwifi-firmware-88w8897
  • mwlwifi-firmware-88w8964

How do you think I should proceed? Thanks!

From what I understand support for mwlwifi stopped a couple of years ago, so you probably won't see any improvement in 21.02, although mwlwifi is still working fine on my wrt1200 on 19.07.7. And the general consensus seems to be that you shouldn't upgrade individual packages because of the limitations in OpenWrt, so it would probably be best to do a clean install of the official 19.07.7 release since David502c no longer maintains his build.

Great - appreciate the reply!