Issues upgrading from DD-WRT to OpenWRT - Archer C7 v4

I'm migrating my wireless infrastructure to OpenWRT. The Linksys and Buffalo devices were a cinch to upgrade. The Archer....not so much. I tried both the factory and the upgrade packages. It says it's upgrading but then reboots back into DD-WRT. I found some instructions that said I needed to reset the original firmware, so I tried. The firmware does the same thing...says it is updating but then reboots back into dd-wrt. I found someone in the OpenWRT forums having the same issue with v2 so I tried that...says it is upgrading and reboots back into DD-WRT...I found directions that say I have to install DD-WRT before I can install OpenWRT, well I'm half way there already! Guess what...says it is updating the firmware and boots right back into DD-WRT.

Found someone say they couldn't update except via command telnet into the Archer C7, wget the firmware, and run write /tmp/firmware.bin linux. Says it's updating...reboots into DD-WRT.

So I tried upgrading DD-WRT to the latest daily just to make sure that I hadn't broken anything. Updated just fine. (And booted back into DD-WRT :wink: ).
Well, now that I'm on the latest version of DD-WRT I might as well try a few things again...when I update either of the OpenWRT firmware images, says it updates but then reboots into DD-WRT...and the factory reset image? Reboots back into DD-WRT. Tried the command line again:

root@DD-WRT:~# write /tmp/firmware.bin linux
flash : /tmp/firmware.bin: Bad trx header

Well, at least it's something different. :slight_smile:

I'm at a loss; nothing but DD-WRT seems to update. What am I doing wrong?
Any help appreciated.

Careful with your experimentation, it's easy to overwrite your radio calibration data (ART) or bootloader that way. Make sure to backup as much as you can and save it securely.

don't know for V4, but for C7V2, I just issue the following:

mtd -f write openwrt-factory linux


That did it! Thank you very much! :confetti_ball:

And just in case someone else needs this tip, I wget the sysupgrade file saving it as /tmp/fimware.bin

root@DD-WRT:~# mtd -f write /tmp/firmware.bin linux
Unlocking linux ...
flash : Could not unlock MTD device: linux
linux: No such file or directory
Writing from /tmp/firmware.bin to linux ...  [w]
Warning unaligned data, we use manual padding to avoid errors. size was 301!!!
root@DD-WRT:~# reboot

And it worked.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.