Issues transferring stock image to Zyxel M1

image

I installed openwrt on M1 and now I want to return to the original software, but I cannot assign files with winscp, I get the error in the picture

You cannot upload files to read-only filesystem. If you paid attention to wiki page you need to copy file to /tmp - a ramdisk.

1 Like

image

i cant do with putty can you help me

Upload with SCP to /tmp?

Im getting error i cant write tmp folder

no, that's not the errors you're getting.

2 Likes

No way, /rom is readonly fileseystem that comes from sysupgrade squashfs, it has empty directories as placehoders for real directories on a running system.

I can't download files with putty even though I have internet, there is an error here

so far there's no proof of any error there ...

image
im trying to do this step but i cant i cant write this file there is nothing inside tmp folder

solved the problem the tmp file was empty, I reinstalled openwrt and now it is full and I can upload files to it

no,

you tried to write it to the wrong folder, something @brada4 pointed out to you, and your router doesn't want to DL the file (for whatever reason), there's no proof of any issues writing any file.

1 Like
root@OpenWRT:~# touch /rom/tmp/zzz
touch: /rom/tmp/zzz: Read-only file system
root@OpenWRT:~# touch /tmp/zzz
root@OpenWRT:~# mount -v
/dev/root on /rom type squashfs (!!!!!!!!!!ro!!!!!!!!!!!,relatime,errors=continue)

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.