Issues setting up simple modem > router bridge

Hey there,

I'm having an issue setting up a simple network. I'm sure the solution is obvious and I've missed it but figured I'd ask.

The setup: Telstra 5G modem > AX9000 running OpenWRT snapshot 2nd June > my laptop

The issue: Can connect to router but can't reach the 5G modem or the internet unless I bridge wan to lan (which I don't want to do - the Telstra modem has been crippled to 10 static DHCP leases)

My /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfe:80eb:6d6d::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan'
	option proto 'static'
	option device 'wan'
	option ipaddr '192.168.0.2'
	option netmask '255.255.255.0'
	option gateway '192.168.0.1'
	list dns '192.168.0.1'

/etc/config/firewall

config defaults
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'

config forwarding
	option src 'lan'
	option dest 'wan'

If you mean interface, you just have to scroll down the code block :slight_smile:
If you mean device, 'wan' is the default name of the 5th port on the router. Should I be defining it again?

Apologies kylemd - i misread your original post.

Hi

looks like Telstra is not on 192.168.0.1

when you bridge WAN & LAN, Telstra start to act as a DHCP server, so it will lease some addresses and this way it will work

are you sure that modem is 192.168.0.1 ?
ping ?

why don't you use simple DHCP client on WAN interface ?

The Telstra modem is definitely on 192.168.0.1 as I can connect to that as long as I have wan and lan bridged.

DHCP and static on wan also both same result.

... but you did not answer a question

does pinging Testra work from OWRT ?

and, what is WAN interface address if you switch to DHCP client protocol ?

Hmm very odd. I've changed WAN to DHCP and it's now working where it wasn't previously.

Final /etc/config/network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfe:80eb:6d6d::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan'
	option proto 'dhcp'
	option device 'wan'


yes, i see in my workplace many gateway device which will simply refuse to act as gateway for static/manually configured client devices
simply need to set client as DHCP client and gateway device will assign IP, then it will work

if your problem is solved, please mark topic as [solved] and mark answer as solution