Issues setting channels list for wireless auto channel selection

I am having some trouble configuring a list of channels that can be used when auto selecting the wireless channel. I have set the wireless.radio1.channels option to a certain set of possible channels. But whenever I reload the wireless interface it keeps choosing a channel which is not in this list. The current output of wifi status is:

{
	"radio0": {
		"up": false,
		"pending": false,
		"autostart": true,
		"disabled": true,
		"retry_setup_failed": false,
		"config": {
			"path": "1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0",
			"channel": "1",
			"band": "2g",
			"htmode": "HT20",
			"disabled": true
		},
		"interfaces": [
			{
				"section": "default_radio0",
				"config": {
					"mode": "ap",
					"ssid": "OpenWrt",
					"encryption": "none",
					"network": [
						"lan"
					],
					"mode": "ap"
				},
				"vlans": [
					
				],
				"stations": [
					
				]
			}
		]
	},
	"radio1": {
		"up": true,
		"pending": false,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": false,
		"config": {
			"path": "1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0",
			"channel": "auto",
			"band": "5g",
			"htmode": "VHT40",
			"country": "NL",
			"cell_density": 0,
			"txpower": 13,
			"channels": [
				"36",
				"48",
				"100",
				"120"
			]
		},
		"interfaces": [
			{
				"section": "default_radio1",
				"ifname": "phy1-ap0",
				"config": {
					"mode": "ap",
					"key": <password>,
					"ssid": <ssid>,
					"encryption": "sae",
					"network": [
						"lan"
					],
					"mode": "ap"
				},
				"vlans": [
					
				],
				"stations": [
					
				]
			},
			{
				"section": "wifinet2",
				"ifname": "phy1-ap1",
				"config": {
					"mode": "ap",
					"ssid": <ssid>,
					"key": <password>,
					"encryption": "sae-mixed",
					"mode": "ap",
					"network": [
						"media"
					]
				},
				"vlans": [
					
				],
				"stations": [
					
				]
			},
			{
				"section": "wifinet5",
				"ifname": "phy1-ap2",
				"config": {
					"mode": "ap",
					"ssid": <ssid>,
					"encryption": "sae",
					"key": <password>,
					"isolate": true,
					"mode": "ap",
					"network": [
						"guest"
					],
					"isolate": true
				},
				"vlans": [
					
				],
				"stations": [
					
				]
			}
		]
	}
}

I am running a snapshot build OpenWrt SNAPSHOT, r22665-626c84340d (due to issues with the partition table that were not yet fixed in the latest stable release) on a Netgear WAC124. What is still missing from my configuration for the auto channel selection to respect the channels list?

Please provide the output of:

/etc/config/network
/etc/config/wireless

See below.

Contents of /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fde8:1cee:5c22::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'static'
	option ipaddr <some ip>
	option netmask <some netmask>
	option gateway <some ip>
	list dns <some ip>
	list dns <some ip>

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'wan'

config interface 'media'
	option proto 'static'
	option device 'br-media'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'

config interface 'guest'
	option proto 'static'
	option device 'br-guest'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'

config device
	option type 'bridge'
	option name 'br-media'
	option bridge_empty '1'

config device
	option type 'bridge'
	option name 'br-guest'
	option bridge_empty '1'

Contents of /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '161'
	option band '5g'
	option htmode 'VHT80'
	option country 'NL'
	option cell_density '0'
	option txpower '13'
	option channels '161 165 169 173'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option key <some key>
	option ssid <some ssid>
	option encryption 'sae'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid <some ssid>
	option network 'media'
	option key <some key>
	option encryption 'sae-mixed'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid <some ssid>
	option encryption 'sae'
	option key <some key>
	option network 'guest'
	option isolate '1'

I played around a bit with the channels list and the behaviour does seem to depend on the channels you include. It seems to be able to auto select one of the lower 5 GHz channels (38 - 50) if they are in the list. With the currently configured list with only the very high channels it doesn't seem to select anything and hangs indefinitely during startup if you choose auto for the channel. If you have a much larger list also including the DFS channels it seems to randomly choose a DFS channel even though it's not in the channels list. Since I was not able to auto select from the channel list I wanted I manually configured a channel for now.