Issues regarding OpenWrt installation on a TL-WA901ND v3

Hi, I tried to install OpenWRT to an old and untested TL-WA901ND v3 router, and I bricked it. So, I decided to use serial console in order to control the install process.

And I opened the case, placed 4 pins into the serial console, used my soldering iron, a USB-TTL converter... Everything that I could find in OpenWRT's wiki.

And I tried to install several firmwares, from stock (TP-Link's one) to OpenWRT and DD-WRT and some undiscovered mysteries to me, like Tanaza firmware. Every firmware boots very well, but there is a moment that we have a lot of garbled characters in the serial port.

Maybe the TL-WL902ND is faulty, I don't know. I'd appreciate any ideas

Thanks in advance,


Maybe the port speed changes for a moment,during initialisation.

I don't think so. Even if the port speed really changed, I would be able to ping the router, at or whatsoever. And the router remains bricked.

As someone gave us these routers (a TD-W8961D, this TD-W901ND and a filthy WRT54G), I'm trying to decide if they can be used, and if we can flash OpenWRT in any of them (maybe the WRT54G). So, any help would be appreciated.

Thanks in advance,


Thanks, I've already read it. I've two old WRT54G here, both of them are using 10.03.1 (Barrier Breaker) firmware and they run pretty well. I decided to not abuse these poor old chaps. :smiley:

But my main concern is the TL-WA901ND v3 router, and why every firmware I install, I have garbage in the serial console when I reboot it.

Thanks in advance, Ricardo.

Without much thought...possibly:

  • serial settings are incorrect
  • not using a null modem cable
  • not using a 5V-to-3.3V TTL Serial Converter
  • Miswired the TX/RX/GRD
  • Accidentally connected VCC/+