Issues on usb and m.2

I am trying to connect an usb device via m.2 on a m7621 device with no success. I compiled the kernel with kmod-usb-net, xhci and other drivers. I tried to include nvme module also but no use. /sys/kernel/debug/usb/devices shows only the two xhci bus controllers, but not my device. Is there any specific driver I need to use the device in this case?

Are you sure that your board routes USB lanes to the m.2 connector? Yes, the standards mandate that, but these devices aren't intended to be user servicable, nor to be standards compliants, so one-off modifications (e.g. leaving off USB functionality), using above/ below standard power requirements or even redefining pins for custom/ non-standard ways (which might even destroy standards compliant cards) are more of a rule, than an exception.

Even if your m.2 slot has USB connected properly, you might still have to enable a custom GPIO to actually enable it (provide USB power).

I hope so. Any way to test that?

Visual inspection, scope, logic analyzer, …

BTW Openwrt Wiki article GPIO contain helpful scripts which simplify the process of search.

I went over the electronics, and it was actually a faulty device. I acquired a brand new device which worked correctly without any changes to drivers, thanks everybody.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.