Issues Installing OpenWrt on NanoPi R2S using Micro SD Card

Hi all,

I recently purchased a NanoPi R2S and I am trying to install OpenWrt onto a micro SD card to use it as a boot drive for r2s. However, I have encountered some issues with writing the OpenWrt image to the micro SD card.

I have tried using both the dd command and Etcher to write the OpenWrt system to the micro SD card, but neither method has been successful. I have also tried using fdisk to partition the micro SD card, but when I exit and check with lsblk, I cannot find any partitions on the card. Additionally, when I try to format the card in Windows 10, I receive an error message saying "Windows was unable to complete the format".

I have even tried using a new micro SD card, but the same issues persist. I am wondering if this could be due to a problem with my card reader, or if there are other issues?

Thank you in advance for your help!

What OpenWrt image are you trying to write? This one?

That doesn't sound too good, although not necessary to format it before writing the image but formating should be possible.
How to you connect the micro SD card to the (Windows only?) computer?

1 Like

What OpenWrt image are you trying to write?This one?

This one included. Also this and many other openwrt derivatives. None of them worked. If I use etcher on linux to write img to sd, I got some error message like this.

That doesn't sound too good, although not necessary to format it before writing the image but formating should be possible.

I formatted it for testing.
I also used a low level disk formatting tool. It stuck at 70% without completing.

That would suggest that the device you're using to connect the micro SD card got issues. It really should be a straightforward thing.

Are you using a USB-to-micro-SD adapter? Or an USB hub with a micro SD slot?

1 Like

The former one I think. Like this.
I will buy a new card reader tomorrow.

I got something like this, a very simple device.

But what I use most is a SD to micro SD adapter like that one. But that would require an SD slot of course but if you got on then the adapter seems very simple, no additional electronics involved (and they came with some micro SD cards I bought).

I neved used a GUI, just dd on linux...
It works just straightforward, if hardware is fine.

So I agree that it looks like a hardware problem.

I got similar problems only on my old HP 8570p Laptop, when using the USB 3 port :(. In effect sometimes all SD's written are messy.
Tried some different USB to Micro SD adapters. All the same problem.
My favorite USB Adapter is a Kingston Mobilite Plus. Faster then my Sandisk adapter, even with samsung or sandisk SD cards ...

But all USB 2 ports in combination with all USB adapters are working fine all the time, while USB 3 was messy.

And mostly after a powercyle the USB 3 port is working fine again for at least an hour. I never had this problems with my Desktop system.
So I guess its a hardware or driver problem on my laptop.

1 Like

Thx for your information.
A bit off topic here. I know little about hardware. Is it true that as long as your operating system has USB drivers, you can always use any USB-to-micro-SD adapter on this system?

I would have hoped so, yes. The USB adapter does all the work necessary and presents a storage device to the OS, like a regular USB stick.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.